[brcm47xx] fix boot failure on some boards
[openwrt/svn-archive/archive.git] / target / linux / brcm47xx / patches-2.6.23 / 130-remove_scache.patch
index eea4e26026b94637c8e3de3571dac887a94eaf1a..8befbf1a85dfbe680b5dec7f55b3180b167ee45c 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.23/arch/mips/Kconfig
-===================================================================
---- linux-2.6.23.orig/arch/mips/Kconfig        2007-10-13 02:23:41.484492317 +0200
-+++ linux-2.6.23/arch/mips/Kconfig     2007-10-13 02:47:02.784347843 +0200
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
 @@ -192,7 +192,6 @@
        select I8259
        select MIPS_BOARDS_GEN
@@ -24,10 +22,8 @@ Index: linux-2.6.23/arch/mips/Kconfig
  config R5000_CPU_SCACHE
        bool
        select BOARD_SCACHE
-Index: linux-2.6.23/arch/mips/kernel/cpu-probe.c
-===================================================================
---- linux-2.6.23.orig/arch/mips/kernel/cpu-probe.c     2007-10-13 02:23:11.210767122 +0200
-+++ linux-2.6.23/arch/mips/kernel/cpu-probe.c  2007-10-13 02:47:02.788348072 +0200
+--- a/arch/mips/kernel/cpu-probe.c
++++ b/arch/mips/kernel/cpu-probe.c
 @@ -701,6 +701,8 @@
                break;
        case PRID_IMP_25KF:
@@ -37,11 +33,9 @@ Index: linux-2.6.23/arch/mips/kernel/cpu-probe.c
                break;
        case PRID_IMP_34K:
                c->cputype = CPU_34K;
-Index: linux-2.6.23/arch/mips/mm/c-r4k.c
-===================================================================
---- linux-2.6.23.orig/arch/mips/mm/c-r4k.c     2007-10-09 22:31:38.000000000 +0200
-+++ linux-2.6.23/arch/mips/mm/c-r4k.c  2007-10-13 02:47:02.792348301 +0200
-@@ -1086,7 +1086,6 @@
+--- a/arch/mips/mm/c-r4k.c
++++ b/arch/mips/mm/c-r4k.c
+@@ -1101,7 +1101,6 @@
  
  extern int r5k_sc_init(void);
  extern int rm7k_sc_init(void);
@@ -49,7 +43,7 @@ Index: linux-2.6.23/arch/mips/mm/c-r4k.c
  
  static void __init setup_scache(void)
  {
-@@ -1140,29 +1139,17 @@
+@@ -1155,29 +1154,17 @@
  #endif
  
        default:
@@ -84,10 +78,8 @@ Index: linux-2.6.23/arch/mips/mm/c-r4k.c
        /* compute a couple of other cache variables */
        c->scache.waysize = scache_size / c->scache.ways;
  
-Index: linux-2.6.23/arch/mips/mm/Makefile
-===================================================================
---- linux-2.6.23.orig/arch/mips/mm/Makefile    2007-10-09 22:31:38.000000000 +0200
-+++ linux-2.6.23/arch/mips/mm/Makefile 2007-10-13 02:47:23.393522295 +0200
+--- a/arch/mips/mm/Makefile
++++ b/arch/mips/mm/Makefile
 @@ -31,6 +31,5 @@
  obj-$(CONFIG_IP22_CPU_SCACHE) += sc-ip22.o
  obj-$(CONFIG_R5000_CPU_SCACHE)  += sc-r5k.o