[generic-2.6] Remove files now present upstream in files-2.6.25
[openwrt/svn-archive/archive.git] / target / linux / brcm47xx / patches-2.6.25 / 700-ssb-gigabit-ethernet-driver.patch
index 1b97d126c9b2d04f8b1c38ec43064245be1fe3bb..ec3f81d1952c0213777369c2e6e03fc86d57aa8a 100644 (file)
@@ -1,8 +1,8 @@
-Index: linux-2.6.23.16/drivers/ssb/Kconfig
+Index: linux-2.6.25.1/drivers/ssb/Kconfig
 ===================================================================
---- linux-2.6.23.16.orig/drivers/ssb/Kconfig   2008-03-19 11:16:18.000000000 +0100
-+++ linux-2.6.23.16/drivers/ssb/Kconfig        2008-03-19 11:16:18.000000000 +0100
-@@ -120,4 +120,13 @@ config SSB_DRIVER_EXTIF
+--- linux-2.6.25.1.orig/drivers/ssb/Kconfig    2008-05-07 22:45:24.000000000 +0100
++++ linux-2.6.25.1/drivers/ssb/Kconfig 2008-05-07 22:57:40.000000000 +0100
+@@ -125,4 +125,13 @@ config SSB_DRIVER_EXTIF
  
          If unsure, say N
  
@@ -16,10 +16,10 @@ Index: linux-2.6.23.16/drivers/ssb/Kconfig
 +        If unsure, say N
 +
  endmenu
-Index: linux-2.6.23.16/drivers/ssb/Makefile
+Index: linux-2.6.25.1/drivers/ssb/Makefile
 ===================================================================
---- linux-2.6.23.16.orig/drivers/ssb/Makefile  2008-03-19 11:16:18.000000000 +0100
-+++ linux-2.6.23.16/drivers/ssb/Makefile       2008-03-19 11:16:18.000000000 +0100
+--- linux-2.6.25.1.orig/drivers/ssb/Makefile   2008-05-07 22:45:24.000000000 +0100
++++ linux-2.6.25.1/drivers/ssb/Makefile        2008-05-07 22:57:40.000000000 +0100
 @@ -11,6 +11,7 @@ ssb-y                                        += driver_chipcommon.o
  ssb-$(CONFIG_SSB_DRIVER_MIPS)         += driver_mipscore.o
  ssb-$(CONFIG_SSB_DRIVER_EXTIF)                += driver_extif.o
@@ -28,10 +28,10 @@ Index: linux-2.6.23.16/drivers/ssb/Makefile
  
  # b43 pci-ssb-bridge driver
  # Not strictly a part of SSB, but kept here for convenience
-Index: linux-2.6.23.16/drivers/ssb/driver_gige.c
+Index: linux-2.6.25.1/drivers/ssb/driver_gige.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23.16/drivers/ssb/driver_gige.c  2008-03-19 11:16:18.000000000 +0100
++++ linux-2.6.25.1/drivers/ssb/driver_gige.c   2008-05-07 22:57:40.000000000 +0100
 @@ -0,0 +1,294 @@
 +/*
 + * Sonics Silicon Backplane
@@ -327,10 +327,10 @@ Index: linux-2.6.23.16/drivers/ssb/driver_gige.c
 +{
 +      return ssb_driver_register(&ssb_gige_driver);
 +}
-Index: linux-2.6.23.16/include/linux/ssb/ssb_driver_gige.h
+Index: linux-2.6.25.1/include/linux/ssb/ssb_driver_gige.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23.16/include/linux/ssb/ssb_driver_gige.h        2008-03-19 11:16:18.000000000 +0100
++++ linux-2.6.25.1/include/linux/ssb/ssb_driver_gige.h 2008-05-07 22:57:40.000000000 +0100
 @@ -0,0 +1,174 @@
 +#ifndef LINUX_SSB_DRIVER_GIGE_H_
 +#define LINUX_SSB_DRIVER_GIGE_H_
@@ -506,11 +506,11 @@ Index: linux-2.6.23.16/include/linux/ssb/ssb_driver_gige.h
 +
 +#endif /* CONFIG_SSB_DRIVER_GIGE */
 +#endif /* LINUX_SSB_DRIVER_GIGE_H_ */
-Index: linux-2.6.23.16/drivers/ssb/driver_pcicore.c
+Index: linux-2.6.25.1/drivers/ssb/driver_pcicore.c
 ===================================================================
---- linux-2.6.23.16.orig/drivers/ssb/driver_pcicore.c  2008-03-19 11:16:18.000000000 +0100
-+++ linux-2.6.23.16/drivers/ssb/driver_pcicore.c       2008-03-19 11:16:18.000000000 +0100
-@@ -60,74 +60,6 @@ static DEFINE_SPINLOCK(cfgspace_lock);
+--- linux-2.6.25.1.orig/drivers/ssb/driver_pcicore.c   2008-05-07 22:45:24.000000000 +0100
++++ linux-2.6.25.1/drivers/ssb/driver_pcicore.c        2008-05-07 22:57:40.000000000 +0100
+@@ -60,78 +60,6 @@ static DEFINE_SPINLOCK(cfgspace_lock);
  /* Core to access the external PCI config space. Can only have one. */
  static struct ssb_pcicore *extpci_core;
  
@@ -565,7 +565,10 @@ Index: linux-2.6.23.16/drivers/ssb/driver_pcicore.c
 -
 -      /* Enable PCI bridge bus mastering and memory space */
 -      pci_set_master(dev);
--      pcibios_enable_device(dev, ~0);
+-      if (pcibios_enable_device(dev, ~0) < 0) {
+-              ssb_printk(KERN_ERR "PCI: SSB bridge enable failed\n");
+-              return;
+-      }
 -
 -      /* Enable PCI bridge BAR1 prefetch and burst */
 -      pci_write_config_dword(dev, SSB_BAR1_CONTROL, 3);
@@ -582,10 +585,11 @@ Index: linux-2.6.23.16/drivers/ssb/driver_pcicore.c
 -{
 -      return ssb_mips_irq(extpci_core->dev) + 2;
 -}
+-
  static u32 get_cfgspace_addr(struct ssb_pcicore *pc,
                             unsigned int bus, unsigned int dev,
-@@ -317,6 +249,92 @@ static struct pci_controller ssb_pcicore
+                            unsigned int func, unsigned int off)
+@@ -320,6 +248,95 @@ static struct pci_controller ssb_pcicore
        .mem_offset     = 0x24000000,
  };
  
@@ -652,7 +656,10 @@ Index: linux-2.6.23.16/drivers/ssb/driver_pcicore.c
 +
 +      /* Enable PCI bridge bus mastering and memory space */
 +      pci_set_master(dev);
-+      pcibios_enable_device(dev, ~0);
++      if (pcibios_enable_device(dev, ~0) < 0) {
++              ssb_printk(KERN_ERR "PCI: SSB bridge enable failed\n");
++              return;
++      }
 +
 +      /* Enable PCI bridge BAR1 prefetch and burst */
 +      pci_write_config_dword(dev, SSB_BAR1_CONTROL, 3);
@@ -678,10 +685,10 @@ Index: linux-2.6.23.16/drivers/ssb/driver_pcicore.c
  static void ssb_pcicore_init_hostmode(struct ssb_pcicore *pc)
  {
        u32 val;
-Index: linux-2.6.23.16/drivers/ssb/embedded.c
+Index: linux-2.6.25.1/drivers/ssb/embedded.c
 ===================================================================
---- linux-2.6.23.16.orig/drivers/ssb/embedded.c        2008-03-19 11:16:18.000000000 +0100
-+++ linux-2.6.23.16/drivers/ssb/embedded.c     2008-03-19 11:16:18.000000000 +0100
+--- linux-2.6.25.1.orig/drivers/ssb/embedded.c 2008-05-07 22:45:24.000000000 +0100
++++ linux-2.6.25.1/drivers/ssb/embedded.c      2008-05-07 22:57:40.000000000 +0100
 @@ -10,6 +10,9 @@
  
  #include <linux/ssb/ssb.h>
@@ -783,11 +790,11 @@ Index: linux-2.6.23.16/drivers/ssb/embedded.c
 +
 +      return -ENODEV;
 +}
-Index: linux-2.6.23.16/include/linux/ssb/ssb.h
+Index: linux-2.6.25.1/include/linux/ssb/ssb.h
 ===================================================================
---- linux-2.6.23.16.orig/include/linux/ssb/ssb.h       2008-03-19 11:16:18.000000000 +0100
-+++ linux-2.6.23.16/include/linux/ssb/ssb.h    2008-03-19 11:16:18.000000000 +0100
-@@ -422,5 +422,12 @@ extern int ssb_bus_powerup(struct ssb_bu
+--- linux-2.6.25.1.orig/include/linux/ssb/ssb.h        2008-05-07 22:45:33.000000000 +0100
++++ linux-2.6.25.1/include/linux/ssb/ssb.h     2008-05-07 22:57:40.000000000 +0100
+@@ -426,5 +426,12 @@ extern int ssb_bus_powerup(struct ssb_bu
  extern u32 ssb_admatch_base(u32 adm);
  extern u32 ssb_admatch_size(u32 adm);
  
@@ -800,10 +807,10 @@ Index: linux-2.6.23.16/include/linux/ssb/ssb.h
 +#endif /* CONFIG_SSB_EMBEDDED */
  
  #endif /* LINUX_SSB_H_ */
-Index: linux-2.6.23.16/include/linux/ssb/ssb_driver_pci.h
+Index: linux-2.6.25.1/include/linux/ssb/ssb_driver_pci.h
 ===================================================================
---- linux-2.6.23.16.orig/include/linux/ssb/ssb_driver_pci.h    2008-03-19 11:16:18.000000000 +0100
-+++ linux-2.6.23.16/include/linux/ssb/ssb_driver_pci.h 2008-03-19 11:16:18.000000000 +0100
+--- linux-2.6.25.1.orig/include/linux/ssb/ssb_driver_pci.h     2008-05-07 22:45:24.000000000 +0100
++++ linux-2.6.25.1/include/linux/ssb/ssb_driver_pci.h  2008-05-07 22:57:40.000000000 +0100
 @@ -1,6 +1,11 @@
  #ifndef LINUX_SSB_PCICORE_H_
  #define LINUX_SSB_PCICORE_H_
@@ -843,10 +850,10 @@ Index: linux-2.6.23.16/include/linux/ssb/ssb_driver_pci.h
 +
  #endif /* CONFIG_SSB_DRIVER_PCICORE */
  #endif /* LINUX_SSB_PCICORE_H_ */
-Index: linux-2.6.23.16/drivers/ssb/main.c
+Index: linux-2.6.25.1/drivers/ssb/main.c
 ===================================================================
---- linux-2.6.23.16.orig/drivers/ssb/main.c    2008-03-19 11:16:18.000000000 +0100
-+++ linux-2.6.23.16/drivers/ssb/main.c 2008-03-19 11:16:18.000000000 +0100
+--- linux-2.6.25.1.orig/drivers/ssb/main.c     2008-05-07 22:45:33.000000000 +0100
++++ linux-2.6.25.1/drivers/ssb/main.c  2008-05-07 22:57:40.000000000 +0100
 @@ -14,6 +14,7 @@
  #include <linux/io.h>
  #include <linux/ssb/ssb.h>
@@ -881,7 +888,7 @@ Index: linux-2.6.23.16/drivers/ssb/main.c
  static struct ssb_device *ssb_device_get(struct ssb_device *dev)
  {
        if (dev)
-@@ -1175,7 +1195,14 @@ static int __init ssb_modinit(void)
+@@ -1181,7 +1201,14 @@ static int __init ssb_modinit(void)
        err = b43_pci_ssb_bridge_init();
        if (err) {
                ssb_printk(KERN_ERR "Broadcom 43xx PCI-SSB-bridge "
@@ -897,7 +904,7 @@ Index: linux-2.6.23.16/drivers/ssb/main.c
                /* don't fail SSB init because of this */
                err = 0;
        }
-@@ -1189,6 +1216,7 @@ fs_initcall(ssb_modinit);
+@@ -1195,6 +1222,7 @@ fs_initcall(ssb_modinit);
  
  static void __exit ssb_modexit(void)
  {
@@ -905,10 +912,10 @@ Index: linux-2.6.23.16/drivers/ssb/main.c
        b43_pci_ssb_bridge_exit();
        bus_unregister(&ssb_bustype);
  }
-Index: linux-2.6.23.16/drivers/ssb/ssb_private.h
+Index: linux-2.6.25.1/drivers/ssb/ssb_private.h
 ===================================================================
---- linux-2.6.23.16.orig/drivers/ssb/ssb_private.h     2008-03-19 11:16:15.000000000 +0100
-+++ linux-2.6.23.16/drivers/ssb/ssb_private.h  2008-03-19 11:16:18.000000000 +0100
+--- linux-2.6.25.1.orig/drivers/ssb/ssb_private.h      2008-05-07 22:45:24.000000000 +0100
++++ linux-2.6.25.1/drivers/ssb/ssb_private.h   2008-05-07 22:57:40.000000000 +0100
 @@ -118,6 +118,8 @@ extern u32 ssb_calc_clock_rate(u32 pllty
  extern int ssb_devices_freeze(struct ssb_bus *bus);
  extern int ssb_devices_thaw(struct ssb_bus *bus);
@@ -917,11 +924,11 @@ Index: linux-2.6.23.16/drivers/ssb/ssb_private.h
 +                        int (*func)(struct ssb_bus *bus, unsigned long data));
  
  /* b43_pci_bridge.c */
- #ifdef CONFIG_SSB_PCIHOST
-Index: linux-2.6.23.16/drivers/net/tg3.c
+ #ifdef CONFIG_SSB_B43_PCI_BRIDGE
+Index: linux-2.6.25.1/drivers/net/tg3.c
 ===================================================================
---- linux-2.6.23.16.orig/drivers/net/tg3.c     2008-03-19 11:16:15.000000000 +0100
-+++ linux-2.6.23.16/drivers/net/tg3.c  2008-03-19 11:16:18.000000000 +0100
+--- linux-2.6.25.1.orig/drivers/net/tg3.c      2008-05-07 22:45:24.000000000 +0100
++++ linux-2.6.25.1/drivers/net/tg3.c   2008-05-07 22:57:40.000000000 +0100
 @@ -38,6 +38,7 @@
  #include <linux/workqueue.h>
  #include <linux/prefetch.h>
@@ -930,7 +937,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
  
  #include <net/checksum.h>
  #include <net/ip.h>
-@@ -410,8 +411,9 @@ static void _tw32_flush(struct tg3 *tp, 
+@@ -425,8 +426,9 @@ static void _tw32_flush(struct tg3 *tp, 
  static inline void tw32_mailbox_flush(struct tg3 *tp, u32 off, u32 val)
  {
        tp->write32_mbox(tp, off, val);
@@ -942,7 +949,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
                tp->read32_mbox(tp, off);
  }
  
-@@ -623,7 +625,7 @@ static void tg3_switch_clocks(struct tg3
+@@ -706,7 +708,7 @@ static void tg3_switch_clocks(struct tg3
  
  #define PHY_BUSY_LOOPS        5000
  
@@ -951,7 +958,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
  {
        u32 frame_val;
        unsigned int loops;
-@@ -637,7 +639,7 @@ static int tg3_readphy(struct tg3 *tp, i
+@@ -720,7 +722,7 @@ static int tg3_readphy(struct tg3 *tp, i
  
        *val = 0x0;
  
@@ -960,7 +967,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
                      MI_COM_PHY_ADDR_MASK);
        frame_val |= ((reg << MI_COM_REG_ADDR_SHIFT) &
                      MI_COM_REG_ADDR_MASK);
-@@ -672,7 +674,12 @@ static int tg3_readphy(struct tg3 *tp, i
+@@ -755,7 +757,12 @@ static int tg3_readphy(struct tg3 *tp, i
        return ret;
  }
  
@@ -974,7 +981,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
  {
        u32 frame_val;
        unsigned int loops;
-@@ -688,7 +695,7 @@ static int tg3_writephy(struct tg3 *tp, 
+@@ -771,7 +778,7 @@ static int tg3_writephy(struct tg3 *tp, 
                udelay(80);
        }
  
@@ -983,8 +990,8 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
                      MI_COM_PHY_ADDR_MASK);
        frame_val |= ((reg << MI_COM_REG_ADDR_SHIFT) &
                      MI_COM_REG_ADDR_MASK);
-@@ -721,6 +728,11 @@ static int tg3_writephy(struct tg3 *tp, 
-       return ret;
+@@ -810,6 +817,11 @@ static void tg3_phydsp_write(struct tg3 
+       tg3_writephy(tp, MII_TG3_DSP_RW_PORT, val);
  }
  
 +static int tg3_writephy(struct tg3 *tp, int reg, u32 val)
@@ -995,22 +1002,22 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
  static void tg3_phy_toggle_automdix(struct tg3 *tp, int enable)
  {
        u32 phy;
-@@ -1988,6 +2000,14 @@ static int tg3_setup_copper_phy(struct t
-               tp->link_config.active_duplex = current_duplex;
-       }
+@@ -2250,6 +2262,14 @@ static int tg3_setup_copper_phy(struct t
+                       }
+               }
  
-+      if (tp->tg3_flags3 & TG3_FLG3_ROBOSWITCH) {
-+              current_link_up = 1;
-+              current_speed = SPEED_1000; //FIXME
-+              current_duplex = DUPLEX_FULL;
-+              tp->link_config.active_speed = current_speed;
-+              tp->link_config.active_duplex = current_duplex;
-+      }
++              if (tp->tg3_flags & TG3_FLG3_ROBOSWITCH) {
++                      current_link_up = 1;
++                      current_speed = SPEED_1000; //FIXME
++                      current_duplex = DUPLEX_FULL;
++                      tp->link_config.active_speed = current_speed;
++                      tp->link_config.active_duplex = current_duplex;
++              }
 +
-       if (current_link_up == 1 &&
-           (tp->link_config.active_duplex == DUPLEX_FULL) &&
-           (tp->link_config.autoneg == AUTONEG_ENABLE)) {
-@@ -4813,6 +4833,11 @@ static int tg3_poll_fw(struct tg3 *tp)
+               if (current_link_up == 1 &&
+                   tp->link_config.active_duplex == DUPLEX_FULL)
+                       tg3_setup_flow_control(tp, lcl_adv, rmt_adv);
+@@ -5197,6 +5217,11 @@ static int tg3_poll_fw(struct tg3 *tp)
        int i;
        u32 val;
  
@@ -1022,7 +1029,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5906) {
                /* Wait up to 20ms for init done. */
                for (i = 0; i < 200; i++) {
-@@ -5040,6 +5065,14 @@ static int tg3_chip_reset(struct tg3 *tp
+@@ -5435,6 +5460,14 @@ static int tg3_chip_reset(struct tg3 *tp
                tw32(0x5000, 0x400);
        }
  
@@ -1037,7 +1044,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        tw32(GRC_MODE, tp->grc_mode);
  
        if (tp->pci_chip_rev_id == CHIPREV_ID_5705_A0) {
-@@ -5308,9 +5341,12 @@ static int tg3_halt_cpu(struct tg3 *tp, 
+@@ -5704,9 +5737,12 @@ static int tg3_halt_cpu(struct tg3 *tp, 
                return -ENODEV;
        }
  
@@ -1053,7 +1060,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        return 0;
  }
  
-@@ -5391,6 +5427,11 @@ static int tg3_load_5701_a0_firmware_fix
+@@ -5787,6 +5823,11 @@ static int tg3_load_5701_a0_firmware_fix
        struct fw_info info;
        int err, i;
  
@@ -1065,7 +1072,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        info.text_base = TG3_FW_TEXT_ADDR;
        info.text_len = TG3_FW_TEXT_LEN;
        info.text_data = &tg3FwText[0];
-@@ -5949,6 +5990,11 @@ static int tg3_load_tso_firmware(struct 
+@@ -6345,6 +6386,11 @@ static int tg3_load_tso_firmware(struct 
        unsigned long cpu_base, cpu_scratch_base, cpu_scratch_size;
        int err, i;
  
@@ -1077,7 +1084,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (tp->tg3_flags2 & TG3_FLG2_HW_TSO)
                return 0;
  
-@@ -6850,6 +6896,11 @@ static void tg3_timer(unsigned long __op
+@@ -7306,6 +7352,11 @@ static void tg3_timer(unsigned long __op
  
        spin_lock(&tp->lock);
  
@@ -1089,9 +1096,9 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (!(tp->tg3_flags & TG3_FLAG_TAGGED_STATUS)) {
                /* All of this garbage is because when using non-tagged
                 * IRQ status the mailbox/status_block protocol the chip
-@@ -8432,6 +8483,11 @@ static int tg3_test_nvram(struct tg3 *tp
-       u32 *buf, csum, magic;
-       int i, j, err = 0, size;
+@@ -8906,6 +8957,11 @@ static int tg3_test_nvram(struct tg3 *tp
+       __le32 *buf;
+       int i, j, k, err = 0, size;
  
 +      if (tp->tg3_flags3 & TG3_FLG3_IS_SSB_CORE) {
 +              /* We don't have NVRAM. */
@@ -1101,7 +1108,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (tg3_nvram_read_swab(tp, 0, &magic) != 0)
                return -EIO;
  
-@@ -9154,7 +9210,7 @@ static int tg3_ioctl(struct net_device *
+@@ -9689,7 +9745,7 @@ static int tg3_ioctl(struct net_device *
                        return -EAGAIN;
  
                spin_lock_bh(&tp->lock);
@@ -1110,7 +1117,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
                spin_unlock_bh(&tp->lock);
  
                data->val_out = mii_regval;
-@@ -9173,7 +9229,7 @@ static int tg3_ioctl(struct net_device *
+@@ -9708,7 +9764,7 @@ static int tg3_ioctl(struct net_device *
                        return -EAGAIN;
  
                spin_lock_bh(&tp->lock);
@@ -1119,7 +1126,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
                spin_unlock_bh(&tp->lock);
  
                return err;
-@@ -9571,6 +9627,12 @@ static void __devinit tg3_get_5906_nvram
+@@ -10177,6 +10233,12 @@ static void __devinit tg3_get_5906_nvram
  /* Chips other than 5700/5701 use the NVRAM for fetching info. */
  static void __devinit tg3_nvram_init(struct tg3 *tp)
  {
@@ -1132,7 +1139,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        tw32_f(GRC_EEPROM_ADDR,
             (EEPROM_ADDR_FSM_RESET |
              (EEPROM_DEFAULT_CLOCK_PERIOD <<
-@@ -9706,6 +9768,9 @@ static int tg3_nvram_read(struct tg3 *tp
+@@ -10317,6 +10379,9 @@ static int tg3_nvram_read(struct tg3 *tp
  {
        int ret;
  
@@ -1142,7 +1149,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (!(tp->tg3_flags & TG3_FLAG_NVRAM))
                return tg3_nvram_read_using_eeprom(tp, offset, val);
  
-@@ -9938,6 +10003,9 @@ static int tg3_nvram_write_block(struct 
+@@ -10563,6 +10628,9 @@ static int tg3_nvram_write_block(struct 
  {
        int ret;
  
@@ -1152,7 +1159,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (tp->tg3_flags & TG3_FLAG_EEPROM_WRITE_PROT) {
                tw32_f(GRC_LOCAL_CTRL, tp->grc_local_ctrl &
                       ~GRC_LCLCTRL_GPIO_OUTPUT1);
-@@ -10804,7 +10872,6 @@ static int __devinit tg3_get_invariants(
+@@ -11610,7 +11678,6 @@ static int __devinit tg3_get_invariants(
                tp->write32 = tg3_write_flush_reg32;
        }
  
@@ -1160,7 +1167,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if ((tp->tg3_flags & TG3_FLAG_TXD_MBOX_HWBUG) ||
            (tp->tg3_flags & TG3_FLAG_MBOX_WRITE_REORDER)) {
                tp->write32_tx_mbox = tg3_write32_tx_mbox;
-@@ -10840,6 +10907,11 @@ static int __devinit tg3_get_invariants(
+@@ -11646,6 +11713,11 @@ static int __devinit tg3_get_invariants(
              GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5701)))
                tp->tg3_flags |= TG3_FLAG_SRAM_USE_CONFIG;
  
@@ -1172,7 +1179,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        /* Get eeprom hw config before calling tg3_set_power_state().
         * In particular, the TG3_FLG2_IS_NIC flag must be
         * determined before calling tg3_set_power_state() so that
-@@ -11184,6 +11256,10 @@ static int __devinit tg3_get_device_addr
+@@ -12017,6 +12089,10 @@ static int __devinit tg3_get_device_addr
        }
  
        if (!is_valid_ether_addr(&dev->dev_addr[0])) {
@@ -1180,10 +1187,10 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
 +                      ssb_gige_get_macaddr(tp->pdev, &dev->dev_addr[0]);
 +      }
 +      if (!is_valid_ether_addr(&dev->dev_addr[0])) {
- #ifdef CONFIG_SPARC64
+ #ifdef CONFIG_SPARC
                if (!tg3_get_default_macaddr_sparc(tp))
                        return 0;
-@@ -11675,6 +11751,7 @@ static char * __devinit tg3_phy_string(s
+@@ -12508,6 +12584,7 @@ static char * __devinit tg3_phy_string(s
        case PHY_ID_BCM5704:    return "5704";
        case PHY_ID_BCM5705:    return "5705";
        case PHY_ID_BCM5750:    return "5750";
@@ -1191,7 +1198,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        case PHY_ID_BCM5752:    return "5752";
        case PHY_ID_BCM5714:    return "5714";
        case PHY_ID_BCM5780:    return "5780";
-@@ -11859,6 +11936,13 @@ static int __devinit tg3_init_one(struct
+@@ -12695,6 +12772,13 @@ static int __devinit tg3_init_one(struct
                tp->msg_enable = tg3_debug;
        else
                tp->msg_enable = TG3_DEF_MSG_ENABLE;
@@ -1205,44 +1212,42 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
  
        /* The word/byte swap controls here control register access byte
         * swapping.  DMA data byte swapping is controlled in the GRC_MODE
-Index: linux-2.6.23.16/drivers/net/tg3.h
+Index: linux-2.6.25.1/drivers/net/tg3.h
 ===================================================================
---- linux-2.6.23.16.orig/drivers/net/tg3.h     2008-03-19 11:16:15.000000000 +0100
-+++ linux-2.6.23.16/drivers/net/tg3.h  2008-03-19 11:16:18.000000000 +0100
-@@ -2279,6 +2279,10 @@ struct tg3 {
- #define TG3_FLG2_PHY_JITTER_BUG               0x20000000
- #define TG3_FLG2_NO_FWARE_REPORTED    0x40000000
- #define TG3_FLG2_PHY_ADJUST_TRIM      0x80000000
-+      u32                             tg3_flags3;
-+#define TG3_FLG3_IS_SSB_CORE          0x00000001
-+#define TG3_FLG3_FLUSH_POSTED_WRITES  0x00000002
-+#define TG3_FLG3_ROBOSWITCH           0x00000004
+--- linux-2.6.25.1.orig/drivers/net/tg3.h      2008-05-07 22:45:24.000000000 +0100
++++ linux-2.6.25.1/drivers/net/tg3.h   2008-05-07 23:02:12.000000000 +0100
+@@ -2477,6 +2477,9 @@ struct tg3 {
+ #define TG3_FLG3_ENABLE_APE           0x00000002
+ #define TG3_FLG3_5761_5784_AX_FIXES   0x00000004
+ #define TG3_FLG3_5701_DMA_BUG         0x00000008
++#define TG3_FLG3_IS_SSB_CORE          0x00000010
++#define TG3_FLG3_FLUSH_POSTED_WRITES  0x00000020
++#define TG3_FLG3_ROBOSWITCH           0x00000040
  
        struct timer_list               timer;
        u16                             timer_counter;
-@@ -2333,6 +2337,7 @@ struct tg3 {
+@@ -2532,6 +2535,7 @@ struct tg3 {
  #define PHY_ID_BCM5714                        0x60008340
  #define PHY_ID_BCM5780                        0x60008350
  #define PHY_ID_BCM5755                        0xbc050cc0
 +#define PHY_ID_BCM5750_2              0xbc050cd0
  #define PHY_ID_BCM5787                        0xbc050ce0
  #define PHY_ID_BCM5756                        0xbc050ed0
- #define PHY_ID_BCM5906                        0xdc00ac40
-@@ -2364,7 +2369,8 @@ struct tg3 {
-        (X) == PHY_ID_BCM5752 || (X) == PHY_ID_BCM5714 || \
+ #define PHY_ID_BCM5784                        0xbc050fa0
+@@ -2568,7 +2572,7 @@ struct tg3 {
         (X) == PHY_ID_BCM5780 || (X) == PHY_ID_BCM5787 || \
         (X) == PHY_ID_BCM5755 || (X) == PHY_ID_BCM5756 || \
--       (X) == PHY_ID_BCM5906 || (X) == PHY_ID_BCM8002)
-+       (X) == PHY_ID_BCM5906 || (X) == PHY_ID_BCM8002 || \
-+       (X) == PHY_ID_BCM5750_2)
+        (X) == PHY_ID_BCM5906 || (X) == PHY_ID_BCM5761 || \
+-       (X) == PHY_ID_BCM8002)
++       (X) == PHY_ID_BCM8002 || (X) == PHY_ID_BCM5750_2)
  
        struct tg3_hw_stats             *hw_stats;
        dma_addr_t                      stats_mapping;
-Index: linux-2.6.23.16/drivers/ssb/driver_mipscore.c
+Index: linux-2.6.25.1/drivers/ssb/driver_mipscore.c
 ===================================================================
---- linux-2.6.23.16.orig/drivers/ssb/driver_mipscore.c 2008-03-19 11:16:18.000000000 +0100
-+++ linux-2.6.23.16/drivers/ssb/driver_mipscore.c      2008-03-19 11:16:18.000000000 +0100
-@@ -211,6 +211,7 @@ void ssb_mipscore_init(struct ssb_mipsco
+--- linux-2.6.25.1.orig/drivers/ssb/driver_mipscore.c  2008-05-07 22:45:33.000000000 +0100
++++ linux-2.6.25.1/drivers/ssb/driver_mipscore.c       2008-05-07 22:57:40.000000000 +0100
+@@ -212,6 +212,7 @@ void ssb_mipscore_init(struct ssb_mipsco
                        /* fallthrough */
                case SSB_DEV_PCI:
                case SSB_DEV_ETHERNET: