Use the new x86 code, thanks sn9 !
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx-2.6 / Makefile
index 0437338e8e221eb888e17251994816c3cb203554..948ff59e4d42871e776bf934115967b1d74157a5 100644 (file)
@@ -6,18 +6,21 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH:=mips
+BOARD:=brcm63xx
+BOARDNAME:=Broadcom BCM963xx
+FEATURES:=squashfs jffs2 broken usb atm
 
-include ./config
-include $(INCLUDE_DIR)/kernel.mk
-include $(INCLUDE_DIR)/kernel-build.mk
+LINUX_VERSION:=2.6.22.1
+
+define Target/Description
+       Build firmware images for Broadcom based xDSL/routers
+       (e.g. Inventel Livebox, Siemens SE515)
+endef
 
+include $(INCLUDE_DIR)/kernel-build.mk
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches $(MAKE_TRACE)
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches $(MAKE_TRACE)
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+# include the profiles
+-include profiles/*.mk
 
+$(eval $(call BuildKernel))