Use the new x86 code, thanks sn9 !
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx-2.6 / Makefile
index b8da70e13386fedcd21dd5f4bc625daf9852db36..948ff59e4d42871e776bf934115967b1d74157a5 100644 (file)
@@ -9,16 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
-FEATURES:=squashfs jffs2 broken
+FEATURES:=squashfs jffs2 broken usb atm
+
+LINUX_VERSION:=2.6.22.1
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
        (e.g. Inventel Livebox, Siemens SE515)
 endef
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
-
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))