clean up a few things in image build makefiles and fix unnecessary grub rebuilds
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx-2.6 / image / Makefile
index 5c16f0541c6d034b9396653fcb4d49a3c701e04e..51c658a0937ae4fc26a9e0ca4048107cfdf2abf2 100644 (file)
@@ -23,7 +23,7 @@ endef
 
 define Image/Prepare
        cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
-       $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) compile
+       $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
 endef
 
 define Image/Build