[brcm63xx] register gpiochip earlier, allowing gpio-based runtime detection to be...
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / Makefile
index 256c33d63e8f703b52bace68bf80748c3bb2ee4c..09b8f6cb78bb5bdc2606883e3aa61f4e7b11f0ba 100644 (file)
@@ -9,17 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 usb atm
-LINUX_VERSION:=2.6.27.13
+FEATURES:=squashfs jffs2 usb atm pci pcmcia
+LINUX_VERSION:=2.6.27.24
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini
+DEFAULT_PACKAGES += hostapd-mini kmod-switch gpioctl
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
        currently supports BCM6348 and BCM6358 based devices.
-       (e.g. Inventel Livebox, Siemens SE515)
+       (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef
 
 $(eval $(call BuildTarget))