[brcm63xx] register gpiochip earlier, allowing gpio-based runtime detection to be...
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / Makefile
index be7dacb7cc6d4b209cb59cb5ea488d113f0ac887..09b8f6cb78bb5bdc2606883e3aa61f4e7b11f0ba 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 usb atm
-LINUX_VERSION:=2.6.27.4
+FEATURES:=squashfs jffs2 usb atm pci pcmcia
+LINUX_VERSION:=2.6.27.24
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += hostapd-mini kmod-switch gpioctl
+
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
        currently supports BCM6348 and BCM6358 based devices.
-       (e.g. Inventel Livebox, Siemens SE515)
+       (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef
 
 $(eval $(call BuildTarget))