[kernel] update to 2.6.27.33
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / Makefile
index e232b00b1e8179c8953d62214a3c300100c5061a..9ba1157dbae18d195c26a676877b58b3495d86e6 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=brcm63xx
-BOARDNAME:=Broadcom BCM963xx
-FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.25.12
+BOARDNAME:=Broadcom BCM63xx
+FEATURES:=squashfs jffs2 usb atm pci pcmcia
+LINUX_VERSION:=2.6.27.33
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += hostapd-mini kmod-switch gpioctl
+
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
-       (e.g. Inventel Livebox, Siemens SE515)
+       currently supports BCM6338, BCM6348 and BCM6358 based devices.
+       (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef
 
 $(eval $(call BuildTarget))