update to 2.6.27.7
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / Makefile
index 32bfd06feaa4a243a5e474400b6207f52b120836..a45a259f0df008b6c860543842f13f669933cce5 100644 (file)
@@ -8,19 +8,16 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=brcm63xx
-BOARDNAME:=Broadcom BCM963xx
-FEATURES:=squashfs jffs2 broken usb atm
+BOARDNAME:=Broadcom BCM63xx
+FEATURES:=squashfs jffs2 usb atm
+LINUX_VERSION:=2.6.27.7
 
-LINUX_VERSION:=2.6.22.4
+include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
+       currently supports BCM6348 and BCM6358 based devices.
        (e.g. Inventel Livebox, Siemens SE515)
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))