[brcm63xx] always select kmod-ssb, pci is supported
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / Makefile
index 9e35957a2b9a44e4f5c92e813a32a9478d19aff9..d16e5a7dd414cb8972b15d21f209da9f301c1cfe 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.27
+FEATURES:=squashfs jffs2 usb atm pci
+LINUX_VERSION:=2.6.27.15
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += hostapd-mini kmod-ssb
+
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
        currently supports BCM6348 and BCM6358 based devices.
-       (e.g. Inventel Livebox, Siemens SE515)
+       (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef
 
 $(eval $(call BuildTarget))