[brcm63xx] add support for 'MAGIC' bcm6348-based board
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / Makefile
index 08667c70ce67d04ae628da9176507c6067811131..e5e2d55dd3feb629a099c1ab5aa965687aa6664c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 usb atm pci
-LINUX_VERSION:=2.6.27.19
+FEATURES:=squashfs jffs2 usb atm pci pcmcia
+LINUX_VERSION:=2.6.35.11
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-ssb
+DEFAULT_PACKAGES += kmod-switch gpioctl kmod-input-gpio-buttons \
+       kmod-leds-gpio kmod-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
-       currently supports BCM6348 and BCM6358 based devices.
+       currently supports BCM6338, BCM6348 and BCM6358 based devices.
        (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef