[brcm63xx] image Makefile: Corrected router imagename length limiting. Thanks KanjiM...
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / image / Makefile
index 2671536e8425accdda5b463cda9483ac33eea7e9..3f532f0b1d754f7c6cd1e9ffaab729be00cfc6dd 100644 (file)
@@ -28,7 +28,7 @@ define trxalign/squashfs
 endef
 
 define Image/LimitName16
-$(shell expr substr "$(1)" 1 $$(expr length "$(1)"))
+$(shell expr substr "$(1)" 1 16)
 endef
 
 define Image/Build/CFE