bcm963xx: image generation using image tagger
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / image / Makefile
index 227dbd7a5469f271574c116083752ec2354db053..47c1df730d40048d0c59c8d30751d3916a8d0bfb 100644 (file)
@@ -27,25 +27,52 @@ define trxalign/squashfs
 -a 1024
 endef
 
+define Image/Build/CFE
+       # Generate the tagged image
+       $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
+               -o $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin \
+               -b $(2) -c $(3) -e $(LOADADDR) -l $(LOADADDR)
+#              -b $(2) -c $(3) -e $(KERNEL_ENTRY) -l $(LOADADDR)
+
+       $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin)
+endef
+
 define Build/Clean
        $(MAKE) -C lzma-loader clean
 endef
 
 define Image/Prepare
+       # Standard LZMA kernel
        cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+
+       # CFE is a LZMA nazi! It took me hours to find out the parameters!
+       # Also I think lzma has a bug cause it generates different output depending on
+       # if you use stdin / stdout or not. Use files instead of stdio here, cause
+       # otherwise CFE will complain and not boot the image.
+       $(STAGING_DIR_HOST)/bin/lzma e -d22 -fb64 -a1 $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma.tmp
+
+       # Strip out the length, CFE doesn't like this
+       dd if=$(KDIR)/vmlinux.lzma.tmp of=$(KDIR)/vmlinux.lzma.cfe bs=5 count=1
+       dd if=$(KDIR)/vmlinux.lzma.tmp of=$(KDIR)/vmlinux.lzma.cfe ibs=13 obs=5 skip=1 seek=1 conv=notrunc
+       rm -f $(KDIR)/vmlinux.lzma.tmp
+
+       # Build the LZMA loader
        rm -f $(KDIR)/loader.gz
        $(MAKE) -C lzma-loader \
                BUILD_DIR="$(KDIR)" \
                TARGET="$(KDIR)" \
                clean install
+
        echo -ne "\\x00" >> $(KDIR)/loader.gz
        rm -f $(KDIR)/fs_mark
        touch $(KDIR)/fs_mark
        $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
+
 endef
 
 define Image/Build
        $(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
+       $(call Image/Build/CFE,$(1),96345GW2,6345)
 endef
 
 $(eval $(call BuildImage))