[brcm63xx] generate experimental images for bcm6338 boards, thanks to Daniel Dickinson
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / image / Makefile
index b6ef968294d1db99db9bfa1d6295843f7fe3da18..c10a41b10ba1b1f80826606e159b6a4a0805edeb 100644 (file)
@@ -30,20 +30,19 @@ endef
 define Image/Build/CFE
        # Generate the tagged image
        $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
-               -o $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin \
-               -b $(2) -c $(3) -e $(LOADADDR) -l $(LOADADDR)
+               -o $(BIN_DIR)/openwrt-$(2)-$(1)-$(6)-cfe.bin \
+               -b $(2) -c $(3) -e $(LOADADDR) -l $(LOADADDR) \
+               -t $(4) -d "$(5)" $(7)
 #              -b $(2) -c $(3) -e $(KERNEL_ENTRY) -l $(LOADADDR)
 
-       $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin)
 endef
 
 define Image/Build/CFEAGPF
        # Generate the tagged image
        $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
-               -o $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin \
+               -o $(BIN_DIR)/openwrt-$(2)-$(1)-$(7)-cfe.bin \
                -b $(2) -c $(3) -e $(LOADADDR) -l $(LOADADDR) \
-               -v 8 -m IMAGE -k 131072 -n $(4)
-       $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin)
+               -v 8 -m IMAGE -k 0x20000 -n $(4) -t $(5)
 endef
 
 define Image/Build/RedBoot
@@ -97,24 +96,73 @@ endef
 define Image/Build
        $(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
-       $(call Image/Build/CFE,$(1),96345GW2,6345)
-       $(call Image/Build/CFE,$(1),96348GW,6348)
+       # Various routers
+       $(call Image/Build/CFE,$(1),96345GW2,6345,bccfe,,bccfe,)
+       $(call Image/Build/CFE,$(1),96345GW2,6345,bc221,,bc221,-y 5)
+       $(call Image/Build/CFE,$(1),96345GW2,6345,bc300,,bc300,)
+       $(call Image/Build/CFE,$(1),96345GW2,6345,bc310,OpenWRT-$(REVISION),bc310,)
+       $(call Image/Build/CFE,$(1),96348GW,6348,bccfe,,bcfe,)
+       $(call Image/Build/CFE,$(1),96348GW,6348,bc221,,bc221,-y 5)
+       # BT Voyager V210_BTR
+       $(call Image/Build/CFE,$(1),V210_BB,6348,bc221,,btvgr,-y 5)
+       # BT Voyager V210_ROI, V210_WB
+       $(call Image/Build/CFE,$(1),V210,6348,bc221,,btvgr,-y 5)
+       # BT Voyager V2091_BTR
+       $(call Image/Build/CFE,$(1),V2091_BB,6348,bc221,,btvgr,-y 5)
+       # BT Voyager V2091_ROI, V2091_WB
+       $(call Image/Build/CFE,$(1),V2091,6348,bc221,,btvgr,-y 5)
+       # BT Voyager V220V, V220V_MGCP_BTR
+       $(call Image/Build/CFE,$(1),RTA1052V,6348,bc221,,btvgr,-y 5)
+       # BT Voyager V2110, V2110_AA, V2110_ROI
+       $(call Image/Build/CFE,$(1),V2110,6348,bc221,,btvgr,-y 5)
+       # BT Voyager V2500V, V2500V_SIP_CLUB, V2500V_AA
+       $(call Image/Build/CFE,$(1),V2500V_BB,6348,bc221,,btvgr,-y 5)
+       # Tecom GW6000
+       $(call Image/Build/CFE,$(1),96348GW,6348,bc300,,bc300,)
+       # Tecom GW6200
+       $(call Image/Build/CFE,$(1),96348GW,6348,bc310,$(shell printf '\x99'),gw6200)
        # Neufbox4
-       $(call Image/Build/CFE,$(1),96358VW,6358)
-       # Comtrend 536
-       $(call Image/Build/CFE,$(1),96348GW-11,6348)
+       $(call Image/Build/CFE,$(1),96358VW,6358,bccfe,,bccfe)
+       $(call Image/Build/CFE,$(1),96358VW,6358,bc310,OpenWRT-$(REVISION),nb4)
+       # Comtrend 536, 5621
+       $(call Image/Build/CFE,$(1),96348GW-11,6348,bccfe,,bccfe)
+       $(call Image/Build/CFE,$(1),96348GW-11,6348,bc300,,bc300)
+       # TP-Link 8900GB
+       $(call Image/Build/CFE,$(1),96348GW-11,6348,bc310,$(shell printf 'PRID\x89\x10\x00\x02'),td8900GB)
        # Davolink DV201AMR
        $(call Image/Build/CFEOLD,$(1),DV201AMR,6348)
        # USR 9108
-       $(call Image/Build/CFE,$(1),96348GW-A,6348)
-       # DG834GT
-       $(call Image/Build/CFE,$(1),96348GW-10,6348)
+       $(call Image/Build/CFE,$(1),96348GW-A,6348,bccfe,,bccfe)
+       $(call Image/Build/CFE,$(1),96348GW-A,6348,bc300,,bc300)
+       # NetGear DG834GT, DG834PN
+       $(call Image/Build/CFE,$(1),96348GW-10,6348,bccfe,,bccfe)
+       $(call Image/Build/CFE,$(1),96348GW-10,6348,bc300,,bc300)
+       # Belkin f5d7633
+       $(call Image/Build/CFE,$(1),96348GW-10,6348,bc310,,bc310)
+       # D-Link DSL-2640B
+       $(call Image/Build/CFE,$(1),D-4P-W,6348,bc310,,bc310)
+
+       # TP-Link TD-8810A, TD-8810B, TD-8811A, TD-8811B
+       $(call Image/Build/CFE,$(1),8L-2M-8M,6338,bccfe,,bccfe)
+       $(call Image/Build/CFE,$(1),8L-2M-8M,6338,bc300,,bc300)
+
+       # Generic 6338 images
+       $(call Image/Build/CFE,$(1),6338GW,6338,bccfe,,bccfe)
+       $(call Image/Build/CFE,$(1),6338GW,6338,bc221,,bc221)
+       $(call Image/Build/CFE,$(1),6338GW,6338,bc300,,bc300)
+       $(call Image/Build/CFE,$(1),6338GW,6338,bc310,,bc310)
+
        # Sagem F@ST2404
-       $(call Image/Build/CFE,$(1),F@ST2404,6348)
+       $(call Image/Build/CFE,$(1),F@ST2404,6348,bccfe,,bccfe)
+       $(call Image/Build/CFE,$(1),F@ST2404,6348,bc300,,bc300)
+       $(call Image/Build/CFE,$(1),F@ST2404,6348,bc310,OpenWRT-$(REVISION),bc310)
        # Inventel Livebox
        $(call Image/Build/RedBoot,livebox)
+       # D-Link DSL-2740B
+       $(call Image/Build/CFE,$(1),96358GW,6358,bc310,,dsl2740b)
        # Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
-       $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358,0x20000)
+       $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358,0x20000,bccfe,,bccfe)
+       $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358,0x20000,ag306,,agv2+w)
 endef
 
 $(eval $(call BuildImage))