[brcm63xx] generate images for old CFE based boards like the Davolink DV201
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / image / Makefile
index 04231b4e855a7f4d46a1a5cafc0133162a6bbbfa..c9a728bbf294a9be956f81ce53a9f9b03f0153cd 100644 (file)
@@ -7,8 +7,8 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-LOADADDR = 0x8108c8f4          # RAM start + 16M 
-KERNEL_ENTRY = 0x80100000      # Default kernel entry in arch/mips/Makefile
+LOADADDR = 0x80010000          # RAM start + 16M 
+KERNEL_ENTRY = $(LOADADDR)     # Newer kernels add a jmp to the kernel_entry at the start of the binary
 RAMSIZE = 0x01000000           # 64MB
 
 LOADER_MAKEOPTS= \
@@ -27,22 +27,81 @@ define trxalign/squashfs
 -a 1024
 endef
 
+define Image/Build/CFE
+       # Generate the tagged image
+       $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
+               -o $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin \
+               -b $(2) -c $(3) -e $(LOADADDR) -l $(LOADADDR)
+#              -b $(2) -c $(3) -e $(KERNEL_ENTRY) -l $(LOADADDR)
+
+       $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin)
+endef
+
+define Image/Build/RedBoot
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(1)-vmlinux.elf
+       gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
+       $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
+       dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(1)-vmlinux.lzma bs=65536 conv=sync
+       dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(1)-vmlinux.gz bs=65536 conv=sync
+endef
+
+define Image/Build/CFEOLD
+       $(TOPDIR)/scripts/brcmImage.pl -t -p    \
+               -b $(2) -c $(3)                 \
+               -k $(KDIR)/vmlinux.lzma.cfe     \
+               -r $(KDIR)/root.$(1)            \
+               -o $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin
+endef
+
 define Build/Clean
        $(MAKE) -C lzma-loader clean
 endef
 
 define Image/Prepare
+       # Standard LZMA kernel
        cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+
+       # CFE is a LZMA nazi! It took me hours to find out the parameters!
+       # Also I think lzma has a bug cause it generates different output depending on
+       # if you use stdin / stdout or not. Use files instead of stdio here, cause
+       # otherwise CFE will complain and not boot the image.
+       $(STAGING_DIR_HOST)/bin/lzma e -d22 -fb64 -a1 $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma.tmp
+
+       # Strip out the length, CFE doesn't like this
+       dd if=$(KDIR)/vmlinux.lzma.tmp of=$(KDIR)/vmlinux.lzma.cfe bs=5 count=1
+       dd if=$(KDIR)/vmlinux.lzma.tmp of=$(KDIR)/vmlinux.lzma.cfe ibs=13 obs=5 skip=1 seek=1 conv=notrunc
+       rm -f $(KDIR)/vmlinux.lzma.tmp
+
+       # Build the LZMA loader
        rm -f $(KDIR)/loader.gz
        $(MAKE) -C lzma-loader \
                BUILD_DIR="$(KDIR)" \
                TARGET="$(KDIR)" \
                clean install
+
        echo -ne "\\x00" >> $(KDIR)/loader.gz
+       rm -f $(KDIR)/fs_mark
+       touch $(KDIR)/fs_mark
+       $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
 endef
 
 define Image/Build
        $(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+       $(call Image/Build/CFE,$(1),96345GW2,6345)
+       $(call Image/Build/CFE,$(1),96348GW,6348)
+       # Neufbox4
+       $(call Image/Build/CFE,$(1),96358VW,6358)
+       # Comtrend 536
+       $(call Image/Build/CFE,$(1),96348GW-11,6348)
+       # Davolink DV201AMR
+       $(call Image/Build/CFEOLD,$(1),DV201AMR,6348)
+       # DG834GT
+       $(call Image/Build/CFE,$(1),96348GW-10,6348)
+       # Sagem F@ST2404
+       $(call Image/Build/CFE,$(1),F@ST2404,6348)
+       # Inventel Livebox
+       $(call Image/Build/RedBoot,livebox)
 endef
 
 $(eval $(call BuildImage))