brcm63xx: BCM963268BU_P300 reference board fixes
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / profiles / broadcom.mk
index 54eed7642a8b12d0384d719107d5b5e3a71ed5bb..8a06a2db0b731dace8df322d35cff861e8a64ea4 100644 (file)
@@ -5,8 +5,26 @@
 # See /LICENSE for more information.
 #
 
+define Profile/BCM96318REF
+  NAME:=Broadcom BCM9618REF reference board
+  PACKAGES:= kmod-b43 wpad-mini kmod-usb-ohci kmod-usb2 kmod-bcm63xx-udc
+endef
+define Profile/BCM96318REF/Description
+  Package set optimized for the Broadcom BCM96318REF reference board.
+endef
+$(eval $(call Profile,BCM96318REF))
+
+define Profile/BCM96318REF_P300
+  NAME:=Broadcom BCM96318REF_P300 reference board
+  PACKAGES:= kmod-b43 wpad-mini kmod-usb-ohci kmod-usb2 kmod-bcm63xx-udc
+endef
+define Profile/BCM96318REF_P300/Description
+  Package set optimized for the Broadcom BCM96318REF_P300 reference board.
+endef
+$(eval $(call Profile,BCM96318REF_P300))
+
 define Profile/BCM963268BU_P300
-  NAME:=Broadcom BCM96328BU_P300 reference board
+  NAME:=Broadcom BCM963268BU_P300 reference board
   PACKAGES:= kmod-usb-ohci kmod-usb2 kmod-bcm63xx-udc
 endef
 define Profile/BCM963268BU_P300/Description