kernel: update 3.10 to 3.10.32
[openwrt/svn-archive/archive.git] / target / linux / cns21xx / Makefile
index ec0685ab156d0700b5af0ef2393611d2dcf098ef..c0fee097fa7bd0053bc2497d425d13e65119723f 100644 (file)
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=cns21xx
 BOARDNAME:=Cavium Networks Econa CNS21xx
-FEATURES:=squashfs broken
-CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
+FEATURES:=squashfs
+CPU_TYPE:=fa526
 
-LINUX_VERSION:=3.3.5
+LINUX_VERSION:=3.10.32
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -24,4 +24,6 @@ define Target/Description
  Build firmware images for Cavium Networks CNS21XX based boards.
 endef
 
+KERNELNAME:="zImage uImage"
+
 $(eval $(call BuildTarget))