targets: remove useless quotes around KERNELNAME
[openwrt/svn-archive/archive.git] / target / linux / cns3xxx / Makefile
index 45faa103c1ec2297b520e74df0d28fa8da827507..dd5349cd6f6264f74cf8bd804aaacb744c7e4f31 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,10 +9,12 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=cns3xxx
 BOARDNAME:=Cavium Networks Econa CNS3xxx
-FEATURES:=squashfs fpu gpio
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time
+FEATURES:=squashfs fpu gpio pcie usb usbgadget
+CPU_TYPE:=mpcore
+CPU_SUBTYPE:=vfp
+MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
-LINUX_VERSION:=2.6.31.14
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -21,6 +23,8 @@ define Target/Description
        eg. the Gateworks Laguna family
 endef
 
-KERNELNAME:="uImage"
+KERNELNAME:=zImage
+
+DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
 
 $(eval $(call BuildTarget))