targets: prepare for supporting normal and initramfs images
[openwrt/svn-archive/archive.git] / target / linux / cns3xxx / image / Makefile
index 6f13fbaf60816621e17e0055073605158e1d89dd..7fa0b35e0603fb5487b549b7953326fd3de179a4 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define mkimage
-       mkimage -A arm -O linux -T kernel -C none -a $(2) -e $(2) -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/uImage-$(1)
+       mkimage -A arm -O linux -T kernel -C none -a $(2) -e $(2) -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage-$(1)
 endef
 
 define Image/Prepare