update kernel versions
[openwrt/svn-archive/archive.git] / target / linux / etrax / Makefile
index db615ce1491780041cf190a940b1296602f26937..a84fe4a7399e1bb58b5dde13efdfd68efa345238 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,25 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=cris
 BOARD:=etrax
-BOARDNAME:=Foxboard (ETRAX 100LX)
-FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.25.4
+BOARDNAME:=Axis ETRAX 100LX
+FEATURES:=squashfs jffs2 usb
+LINUX_VERSION:=2.6.32.16
+DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="zImage"
-DEFAULT_PACKAGES += foxboard-utils
 
 define Target/Description
-       Build fimware images for the FOXBOARD made by acmesystems.it
+       Build firmware images for the FOXBOARD made by acmesystems.it
+endef
+
+define Kernel/Prepare
+       $(call Kernel/Prepare/Default)
+       mkdir -p $(LINUX_DIR)/include/asm-cris
+       $(CP) $(LINUX_DIR)/arch/cris/include/asm/*.h $(LINUX_DIR)/include/asm-cris
+       mkdir -p $(LINUX_DIR)/include/asm-cris/arch
+       $(CP) $(LINUX_DIR)/arch/cris/include/arch-v10/arch/*.h $(LINUX_DIR)/include/asm-cris/arch
 endef
 
 $(eval $(call BuildTarget))
-$(eval $(call RequireCommand,/usr/local/cris/gcc-cris, \
-       Please install the binary cris toolchain. \
-))