upgrade to 2.6.25.9
[openwrt/svn-archive/archive.git] / target / linux / etrax / Makefile
index c837550062414a9cb0c45e66bbab5e1d2cc0a4be..b61f017c7eb857882e703805287e1ab8474e9e72 100644 (file)
@@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
 ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
-FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.19.2
+FEATURES:=squashfs jffs2 broken
+LINUX_VERSION:=2.6.25.9
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -21,23 +21,4 @@ define Target/Description
        Build fimware images for the FOXBOARD made by acmesystems.it
 endef
 
-define Kernel/Prepare/Fox
-       bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-       if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
-       if [ -d ./patches/generic_2.6 ]; then $(PATCH) $(LINUX_DIR) ./patches/generic_2.6; fi
-       if [ -d ./patches/cris ]; then $(PATCH) $(LINUX_DIR) ./patches/cris; fi
-       ln -sf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/include/asm-cris/arch-v10 $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/include/asm-cris/arch
-       ln -sf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/arch/cris/arch-v10 $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/arch/cris/arch
-endef
-
-define Kernel/Prepare
-       $(call Kernel/Prepare/Fox)
-endef
-
-#include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
-$(eval $(call RequireCommand,/usr/local/cris/gcc-cris, \
-       Please install the binary cris toolchain. \
-))