upgrade to 2.6.30-rc8
[openwrt/svn-archive/archive.git] / target / linux / etrax / Makefile
index 7c9b76fa65a32a82f39686e2d52607e1abbc6967..b90a45cae5f9d51ec064ccccf2d3a859512f0381 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,35 +10,15 @@ ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
 FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.19.2
-
-include $(INCLUDE_DIR)/kernel-build.mk
+LINUX_VERSION:=2.6.30-rc8
+DEVICE_TYPE=
 
-define Target/Description
-       Build fimware images for the FOXBOARD made by acmesystems.it
-endef
+include $(INCLUDE_DIR)/target.mk
 
-define Kernel/Prepare/Fox
-       bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-       if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
-       if [ -d ./patches/generic_2.6 ]; then $(PATCH) $(LINUX_DIR) ./patches/generic_2.6; fi
-       if [ -d ./patches/cris ]; then $(PATCH) $(LINUX_DIR) ./patches/cris; fi
-       ln -sf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/include/asm-cris/arch-v10 $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/include/asm-cris/arch
-       ln -sf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/arch/cris/arch-v10 $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/arch/cris/arch
-endef
+KERNELNAME:="zImage"
 
-define Kernel/Prepare
-       $(call Kernel/Prepare/Fox)
+define Target/Description
+       Build firmware images for the FOXBOARD made by acmesystems.it
 endef
 
-DEFAULT_PACKAGES += foxboard-utils
-
-$(eval $(call RequireCommand,/usr/local/cris/gcc-cris, \
-       Please install the binary cris toolchain. \
-))
-
-#include the profiles
--include profiles/*.mk
-
-KERNELNAME:="zImage"
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))