add some extra kernel exports to be used by ashmem and binder later
[openwrt/svn-archive/archive.git] / target / linux / etrax / Makefile
index 7c9b76fa65a32a82f39686e2d52607e1abbc6967..e9a33c5828e0314efa3941de1f10f37dfcd5ee98 100644 (file)
@@ -9,36 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
-FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.19.2
+FEATURES:=squashfs jffs2 broken
+LINUX_VERSION:=2.6.25.20
 
-include $(INCLUDE_DIR)/kernel-build.mk
+include $(INCLUDE_DIR)/target.mk
 
-define Target/Description
-       Build fimware images for the FOXBOARD made by acmesystems.it
-endef
-
-define Kernel/Prepare/Fox
-       bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-       if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
-       if [ -d ./patches/generic_2.6 ]; then $(PATCH) $(LINUX_DIR) ./patches/generic_2.6; fi
-       if [ -d ./patches/cris ]; then $(PATCH) $(LINUX_DIR) ./patches/cris; fi
-       ln -sf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/include/asm-cris/arch-v10 $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/include/asm-cris/arch
-       ln -sf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/arch/cris/arch-v10 $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/arch/cris/arch
-endef
+KERNELNAME:="zImage"
 
-define Kernel/Prepare
-       $(call Kernel/Prepare/Fox)
+define Target/Description
+       Build firmware images for the FOXBOARD made by acmesystems.it
 endef
 
-DEFAULT_PACKAGES += foxboard-utils
-
-$(eval $(call RequireCommand,/usr/local/cris/gcc-cris, \
-       Please install the binary cris toolchain. \
-))
-
-#include the profiles
--include profiles/*.mk
-
-KERNELNAME:="zImage"
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))