update kernel from 2.6.32.7 to 2.6.32.8, thanks tripolar
[openwrt/svn-archive/archive.git] / target / linux / etrax / Makefile
index 2ac747cd0d716c3795faef43dc62a07b18ef87b0..ec93e06f56e292dd642972965670e5bd93269f5c 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,19 +9,24 @@ include $(TOPDIR)/rules.mk
 ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
-FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.25
+FEATURES:=squashfs jffs2
+LINUX_VERSION:=2.6.32.8
+DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="zImage"
-DEFAULT_PACKAGES += foxboard-utils
 
 define Target/Description
-       Build fimware images for the FOXBOARD made by acmesystems.it
+       Build firmware images for the FOXBOARD made by acmesystems.it
+endef
+
+define Kernel/Prepare
+       $(call Kernel/Prepare/Default)
+       mkdir -p $(LINUX_DIR)/include/asm-cris
+       $(CP) $(LINUX_DIR)/arch/cris/include/asm/*.h $(LINUX_DIR)/include/asm-cris
+       mkdir -p $(LINUX_DIR)/include/asm-cris/arch
+       $(CP) $(LINUX_DIR)/arch/cris/include/arch-v10/arch/*.h $(LINUX_DIR)/include/asm-cris/arch
 endef
 
 $(eval $(call BuildTarget))
-$(eval $(call RequireCommand,/usr/local/cris/gcc-cris, \
-       Please install the binary cris toolchain. \
-))