[kernel] add patch from #4850 to make hdparm work on usb drivers (#4850)
[openwrt/svn-archive/archive.git] / target / linux / generic-2.4 / patches / 001-squashfs.patch
index e6751fd1d05268fd54a7077dd202d39c365b43af..2e5cefedf792d6f5a06b7d866c54317b3ad27c8a 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.4.35.4/fs/Config.in
-===================================================================
---- linux-2.4.35.4.orig/fs/Config.in   2007-12-15 05:19:42.758857728 +0100
-+++ linux-2.4.35.4/fs/Config.in        2007-12-15 05:19:48.635192599 +0100
-@@ -51,6 +51,14 @@
+--- a/fs/Config.in
++++ b/fs/Config.in
+@@ -51,6 +51,14 @@ if [ "$CONFIG_JFFS2_FS" = "y" -o "$CONFI
     int 'JFFS2 debugging verbosity (0 = quiet, 2 = noisy)' CONFIG_JFFS2_FS_DEBUG 0
  fi
  tristate 'Compressed ROM file system support' CONFIG_CRAMFS
@@ -17,11 +15,9 @@ Index: linux-2.4.35.4/fs/Config.in
  bool 'Virtual memory file system support (former shm fs)' CONFIG_TMPFS
  define_bool CONFIG_RAMFS y
  
-Index: linux-2.4.35.4/fs/Makefile
-===================================================================
---- linux-2.4.35.4.orig/fs/Makefile    2007-12-15 05:19:42.766858183 +0100
-+++ linux-2.4.35.4/fs/Makefile 2007-12-15 05:19:48.639192828 +0100
-@@ -65,6 +65,7 @@
+--- a/fs/Makefile
++++ b/fs/Makefile
+@@ -65,6 +65,7 @@ subdir-$(CONFIG_REISERFS_FS) += reiserfs
  subdir-$(CONFIG_DEVPTS_FS)    += devpts
  subdir-$(CONFIG_SUN_OPENPROMFS)       += openpromfs
  subdir-$(CONFIG_BEFS_FS)      += befs
@@ -29,10 +25,8 @@ Index: linux-2.4.35.4/fs/Makefile
  subdir-$(CONFIG_JFS_FS)               += jfs
  subdir-$(CONFIG_XFS_FS)               += xfs
  
-Index: linux-2.4.35.4/fs/squashfs/inode.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.4.35.4/fs/squashfs/inode.c 2007-12-15 05:19:48.647193283 +0100
+--- /dev/null
++++ b/fs/squashfs/inode.c
 @@ -0,0 +1,2028 @@
 +/*
 + * Squashfs - a compressed read only filesystem for Linux
@@ -2062,10 +2056,8 @@ Index: linux-2.4.35.4/fs/squashfs/inode.c
 +MODULE_DESCRIPTION("squashfs, a compressed read-only filesystem");
 +MODULE_AUTHOR("Phillip Lougher <phillip@lougher.org.uk>");
 +MODULE_LICENSE("GPL");
-Index: linux-2.4.35.4/fs/squashfs/Makefile
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.4.35.4/fs/squashfs/Makefile        2007-12-15 05:19:48.651193513 +0100
+--- /dev/null
++++ b/fs/squashfs/Makefile
 @@ -0,0 +1,11 @@
 +#
 +# Makefile for the linux squashfs routines.
@@ -2078,10 +2070,8 @@ Index: linux-2.4.35.4/fs/squashfs/Makefile
 +obj-m := $(O_TARGET)
 +
 +include $(TOPDIR)/Rules.make
-Index: linux-2.4.35.4/fs/squashfs/squashfs2_0.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.4.35.4/fs/squashfs/squashfs2_0.c   2007-12-15 05:19:48.655193739 +0100
+--- /dev/null
++++ b/fs/squashfs/squashfs2_0.c
 @@ -0,0 +1,751 @@
 +/*
 + * Squashfs - a compressed read only filesystem for Linux
@@ -2834,10 +2824,8 @@ Index: linux-2.4.35.4/fs/squashfs/squashfs2_0.c
 +
 +      return 1;
 +}
-Index: linux-2.4.35.4/fs/squashfs/squashfs.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.4.35.4/fs/squashfs/squashfs.h      2007-12-15 05:19:48.659193968 +0100
+--- /dev/null
++++ b/fs/squashfs/squashfs.h
 @@ -0,0 +1,85 @@
 +/*
 + * Squashfs - a compressed read only filesystem for Linux
@@ -2924,11 +2912,9 @@ Index: linux-2.4.35.4/fs/squashfs/squashfs.h
 +      return 0;
 +}
 +#endif
-Index: linux-2.4.35.4/include/linux/fs.h
-===================================================================
---- linux-2.4.35.4.orig/include/linux/fs.h     2007-12-15 05:19:42.794859778 +0100
-+++ linux-2.4.35.4/include/linux/fs.h  2007-12-15 05:19:48.663194197 +0100
-@@ -324,6 +324,7 @@
+--- a/include/linux/fs.h
++++ b/include/linux/fs.h
+@@ -324,6 +324,7 @@ extern void set_bh_page(struct buffer_he
  #include <linux/usbdev_fs_i.h>
  #include <linux/jffs2_fs_i.h>
  #include <linux/cramfs_fs_sb.h>
@@ -2936,7 +2922,7 @@ Index: linux-2.4.35.4/include/linux/fs.h
  
  /*
   * Attribute flags.  These should be or-ed together to figure out what
-@@ -519,6 +520,7 @@
+@@ -519,6 +520,7 @@ struct inode {
                struct socket                   socket_i;
                struct usbdev_inode_info        usbdev_i;
                struct jffs2_inode_info         jffs2_i;
@@ -2944,7 +2930,7 @@ Index: linux-2.4.35.4/include/linux/fs.h
                void                            *generic_ip;
        } u;
  };
-@@ -734,6 +736,7 @@
+@@ -736,6 +738,7 @@ struct nameidata {
  #include <linux/usbdev_fs_sb.h>
  #include <linux/cramfs_fs_sb.h>
  #include <linux/jffs2_fs_sb.h>
@@ -2952,7 +2938,7 @@ Index: linux-2.4.35.4/include/linux/fs.h
  
  extern struct list_head super_blocks;
  extern spinlock_t sb_lock;
-@@ -793,6 +796,7 @@
+@@ -795,6 +798,7 @@ struct super_block {
                struct usbdev_sb_info   usbdevfs_sb;
                struct jffs2_sb_info    jffs2_sb;
                struct cramfs_sb_info   cramfs_sb;
@@ -2960,10 +2946,8 @@ Index: linux-2.4.35.4/include/linux/fs.h
                void                    *generic_sbp;
        } u;
        /*
-Index: linux-2.4.35.4/include/linux/squashfs_fs.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.4.35.4/include/linux/squashfs_fs.h 2007-12-15 05:19:48.663194197 +0100
+--- /dev/null
++++ b/include/linux/squashfs_fs.h
 @@ -0,0 +1,915 @@
 +#ifndef SQUASHFS_FS
 +#define SQUASHFS_FS
@@ -3880,10 +3864,8 @@ Index: linux-2.4.35.4/include/linux/squashfs_fs.h
 +
 +#endif
 +#endif
-Index: linux-2.4.35.4/include/linux/squashfs_fs_i.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.4.35.4/include/linux/squashfs_fs_i.h       2007-12-15 05:19:48.663194197 +0100
+--- /dev/null
++++ b/include/linux/squashfs_fs_i.h
 @@ -0,0 +1,44 @@
 +#ifndef SQUASHFS_FS_I
 +#define SQUASHFS_FS_I
@@ -3929,10 +3911,8 @@ Index: linux-2.4.35.4/include/linux/squashfs_fs_i.h
 +      } u;
 +};
 +#endif
-Index: linux-2.4.35.4/include/linux/squashfs_fs_sb.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.4.35.4/include/linux/squashfs_fs_sb.h      2007-12-15 05:19:48.667194423 +0100
+--- /dev/null
++++ b/include/linux/squashfs_fs_sb.h
 @@ -0,0 +1,74 @@
 +#ifndef SQUASHFS_FS_SB
 +#define SQUASHFS_FS_SB
@@ -4008,11 +3988,9 @@ Index: linux-2.4.35.4/include/linux/squashfs_fs_sb.h
 +      int                     (*read_fragment_index_table)(struct super_block *s);
 +};
 +#endif
-Index: linux-2.4.35.4/init/do_mounts.c
-===================================================================
---- linux-2.4.35.4.orig/init/do_mounts.c       2007-12-15 05:19:42.822861373 +0100
-+++ linux-2.4.35.4/init/do_mounts.c    2007-12-15 05:19:48.667194423 +0100
-@@ -15,6 +15,7 @@
+--- a/init/do_mounts.c
++++ b/init/do_mounts.c
+@@ -16,6 +16,7 @@
  #include <linux/minix_fs.h>
  #include <linux/ext2_fs.h>
  #include <linux/romfs_fs.h>
@@ -4020,7 +3998,7 @@ Index: linux-2.4.35.4/init/do_mounts.c
  #include <linux/cramfs_fs.h>
  
  #define BUILD_CRAMDISK
-@@ -476,6 +477,7 @@
+@@ -485,6 +486,7 @@ static int __init crd_load(int in_fd, in
   *    minix
   *    ext2
   *    romfs
@@ -4028,7 +4006,7 @@ Index: linux-2.4.35.4/init/do_mounts.c
   *    cramfs
   *    gzip
   */
-@@ -486,6 +488,7 @@
+@@ -495,6 +497,7 @@ identify_ramdisk_image(int fd, int start
        struct minix_super_block *minixsb;
        struct ext2_super_block *ext2sb;
        struct romfs_super_block *romfsb;
@@ -4036,7 +4014,7 @@ Index: linux-2.4.35.4/init/do_mounts.c
        struct cramfs_super *cramfsb;
        int nblocks = -1;
        unsigned char *buf;
-@@ -497,6 +500,7 @@
+@@ -506,6 +509,7 @@ identify_ramdisk_image(int fd, int start
        minixsb = (struct minix_super_block *) buf;
        ext2sb = (struct ext2_super_block *) buf;
        romfsb = (struct romfs_super_block *) buf;
@@ -4044,7 +4022,7 @@ Index: linux-2.4.35.4/init/do_mounts.c
        cramfsb = (struct cramfs_super *) buf;
        memset(buf, 0xe5, size);
  
-@@ -535,6 +539,15 @@
+@@ -544,6 +548,15 @@ identify_ramdisk_image(int fd, int start
                goto done;
        }
  
@@ -4060,11 +4038,9 @@ Index: linux-2.4.35.4/init/do_mounts.c
        /*
         * Read block 1 to test for minix and ext2 superblock
         */
-Index: linux-2.4.35.4/lib/Config.in
-===================================================================
---- linux-2.4.35.4.orig/lib/Config.in  2007-12-15 05:19:42.830861829 +0100
-+++ linux-2.4.35.4/lib/Config.in       2007-12-15 05:19:48.667194423 +0100
-@@ -10,6 +10,7 @@
+--- a/lib/Config.in
++++ b/lib/Config.in
+@@ -10,6 +10,7 @@ tristate 'CRC32 functions' CONFIG_CRC32
  # Do we need the compression support?
  #
  if [ "$CONFIG_CRAMFS" = "y" -o \
@@ -4072,7 +4048,7 @@ Index: linux-2.4.35.4/lib/Config.in
       "$CONFIG_PPP_DEFLATE" = "y" -o \
       "$CONFIG_CRYPTO_DEFLATE" = "y" -o \
       "$CONFIG_JFFS2_FS" = "y" -o \
-@@ -17,6 +18,7 @@
+@@ -17,6 +18,7 @@ if [ "$CONFIG_CRAMFS" = "y" -o \
     define_tristate CONFIG_ZLIB_INFLATE y
  else
    if [ "$CONFIG_CRAMFS" = "m" -o \