remove 'svn:keywords' property, not needed anymore after [15242]
[openwrt/svn-archive/archive.git] / target / linux / generic-2.4 / patches / 610-netfilter_connbytes.patch
index f903bc9ea2b482d550978c86108ce5e7a0e05e4b..42932f72762634158dbe08613c83332d0bdba881 100644 (file)
@@ -1,8 +1,8 @@
 Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
 ===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/Config.in   2007-12-15 05:20:08.396318720 +0100
-+++ linux-2.4.35.4/net/ipv4/netfilter/Config.in        2007-12-15 05:20:08.692335591 +0100
-@@ -11,6 +11,8 @@
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/Config.in
++++ linux-2.4.35.4/net/ipv4/netfilter/Config.in
+@@ -11,6 +11,8 @@ if [ "$CONFIG_IP_NF_CONNTRACK" != "n" ];
    dep_tristate '  Amanda protocol support' CONFIG_IP_NF_AMANDA $CONFIG_IP_NF_CONNTRACK
    dep_tristate '  TFTP protocol support' CONFIG_IP_NF_TFTP $CONFIG_IP_NF_CONNTRACK
    dep_tristate '  IRC protocol support' CONFIG_IP_NF_IRC $CONFIG_IP_NF_CONNTRACK
@@ -13,9 +13,9 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
  fi
 Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
 ===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/Makefile    2007-12-15 05:20:08.400318949 +0100
-+++ linux-2.4.35.4/net/ipv4/netfilter/Makefile 2007-12-15 05:20:08.696335817 +0100
-@@ -106,6 +106,7 @@
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/Makefile
++++ linux-2.4.35.4/net/ipv4/netfilter/Makefile
+@@ -106,6 +106,7 @@ obj-$(CONFIG_IP_NF_MATCH_LENGTH) += ipt_
  obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
  obj-$(CONFIG_IP_NF_MATCH_STATE) += ipt_state.o
  obj-$(CONFIG_IP_NF_MATCH_CONNMARK) += ipt_connmark.o
@@ -25,9 +25,9 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
  obj-$(CONFIG_IP_NF_MATCH_STRING) += ipt_string.o
 Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_amanda.c
 ===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_amanda.c       2007-12-15 05:19:37.650566622 +0100
-+++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_amanda.c    2007-12-15 05:20:08.700336046 +0100
-@@ -75,7 +75,7 @@
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_amanda.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_amanda.c
+@@ -75,7 +75,7 @@ static int help(const struct iphdr *iph,
  
        /* increase the UDP timeout of the master connection as replies from
         * Amanda clients to the server can be quite delayed */
@@ -38,9 +38,9 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_amanda.c
        do {
 Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_tcp.c
 ===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_tcp.c    2007-12-15 05:19:37.658567077 +0100
-+++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_tcp.c 2007-12-15 05:20:08.700336046 +0100
-@@ -211,7 +211,7 @@
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_tcp.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_tcp.c
+@@ -211,7 +211,7 @@ static int tcp_packet(struct ip_conntrac
                        set_bit(IPS_ASSURED_BIT, &conntrack->status);
  
                WRITE_UNLOCK(&tcp_lock);
@@ -51,9 +51,9 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_tcp.c
        return NF_ACCEPT;
 Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_udp.c
 ===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_udp.c    2007-12-15 05:19:37.666567533 +0100
-+++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_udp.c 2007-12-15 05:20:08.700336046 +0100
-@@ -47,16 +47,16 @@
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_udp.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_udp.c
+@@ -47,16 +47,16 @@ static unsigned int udp_print_conntrack(
  /* Returns verdict for packet, and may modify conntracktype */
  static int udp_packet(struct ip_conntrack *conntrack,
                      struct iphdr *iph, size_t len,
@@ -75,9 +75,9 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_udp.c
  }
 Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_standalone.c
 ===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_standalone.c   2007-12-15 05:20:07.568271536 +0100
-+++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_standalone.c        2007-12-15 05:20:08.700336046 +0100
-@@ -79,6 +79,18 @@
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_standalone.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_standalone.c
+@@ -79,6 +79,18 @@ print_expect(char *buffer, const struct 
        return len;
  }
  
@@ -96,7 +96,7 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_standalone.c
  static unsigned int
  print_conntrack(char *buffer, struct ip_conntrack *conntrack)
  {
-@@ -98,11 +110,15 @@
+@@ -98,11 +110,15 @@ print_conntrack(char *buffer, struct ip_
        len += print_tuple(buffer + len,
                           &conntrack->tuplehash[IP_CT_DIR_ORIGINAL].tuple,
                           proto);
@@ -112,7 +112,7 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_standalone.c
        if (test_bit(IPS_ASSURED_BIT, &conntrack->status))
                len += sprintf(buffer + len, "[ASSURED] ");
        len += sprintf(buffer + len, "use=%u ",
-@@ -478,7 +494,7 @@
+@@ -478,7 +494,7 @@ EXPORT_SYMBOL(ip_conntrack_get);
  EXPORT_SYMBOL(ip_conntrack_helper_register);
  EXPORT_SYMBOL(ip_conntrack_helper_unregister);
  EXPORT_SYMBOL(ip_ct_iterate_cleanup);
@@ -123,9 +123,9 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_standalone.c
  EXPORT_SYMBOL(ip_ct_find_helper);
 Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_generic.c
 ===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_generic.c        2007-12-15 05:19:37.682568446 +0100
-+++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_generic.c     2007-12-15 05:20:08.700336046 +0100
-@@ -41,9 +41,9 @@
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_generic.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_generic.c
+@@ -41,9 +41,9 @@ static unsigned int generic_print_conntr
  /* Returns verdict for packet, or -1 for invalid. */
  static int established(struct ip_conntrack *conntrack,
                       struct iphdr *iph, size_t len,
@@ -139,9 +139,9 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_generic.c
  
 Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_icmp.c
 ===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_icmp.c   2007-12-15 05:19:37.686568672 +0100
-+++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_icmp.c        2007-12-15 05:20:08.704336275 +0100
-@@ -82,7 +82,7 @@
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_icmp.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_icmp.c
+@@ -82,7 +82,7 @@ static int icmp_packet(struct ip_conntra
                        ct->timeout.function((unsigned long)ct);
        } else {
                atomic_inc(&ct->proto.icmp.count);
@@ -152,9 +152,9 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_icmp.c
        return NF_ACCEPT;
 Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_core.c
 ===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_core.c 2007-12-15 05:20:07.568271536 +0100
-+++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_core.c      2007-12-15 05:20:08.704336275 +0100
-@@ -1196,22 +1196,40 @@
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_core.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_core.c
+@@ -1196,22 +1196,40 @@ void ip_conntrack_helper_unregister(stru
  
        MOD_DEC_USE_COUNT;
  }
@@ -200,9 +200,9 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_core.c
  }
 Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
 ===================================================================
---- linux-2.4.35.4.orig/include/linux/netfilter_ipv4/ip_conntrack.h    2007-12-15 05:20:07.552270623 +0100
-+++ linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h 2007-12-15 05:20:08.704336275 +0100
-@@ -164,6 +164,12 @@
+--- linux-2.4.35.4.orig/include/linux/netfilter_ipv4/ip_conntrack.h
++++ linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
+@@ -164,6 +164,12 @@ struct ip_conntrack_expect
        union ip_conntrack_expect_help help;
  };
  
@@ -215,7 +215,7 @@ Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
  struct ip_conntrack_helper;
  
  struct ip_conntrack
-@@ -181,6 +187,12 @@
+@@ -181,6 +187,12 @@ struct ip_conntrack
        /* Timer function; drops refcnt when it goes off. */
        struct timer_list timeout;
  
@@ -228,7 +228,7 @@ Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
        /* If we're expecting another related connection, this will be
             in expected linked list */
        struct list_head sibling_list;
-@@ -264,8 +276,10 @@
+@@ -264,8 +276,10 @@ extern int invert_tuplepr(struct ip_conn
                          const struct ip_conntrack_tuple *orig);
  
  /* Refresh conntrack for this many jiffies */
@@ -243,8 +243,8 @@ Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
  /* Call me when a conntrack is destroyed. */
 Index: linux-2.4.35.4/net/ipv4/netfilter/ipt_connbytes.c
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.4.35.4/net/ipv4/netfilter/ipt_connbytes.c  2007-12-15 05:20:08.704336275 +0100
+--- /dev/null
++++ linux-2.4.35.4/net/ipv4/netfilter/ipt_connbytes.c
 @@ -0,0 +1,163 @@
 +/* Kernel module to match connection tracking byte counter.
 + * GPL (C) 2002 Martin Devera (devik@cdi.cz).
@@ -411,8 +411,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ipt_connbytes.c
 +MODULE_LICENSE("GPL");
 Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_connbytes.h
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_connbytes.h        2007-12-15 05:20:08.708336505 +0100
+--- /dev/null
++++ linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_connbytes.h
 @@ -0,0 +1,25 @@
 +#ifndef _IPT_CONNBYTES_H
 +#define _IPT_CONNBYTES_H
@@ -441,9 +441,9 @@ Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_connbytes.h
 +#endif
 Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_gre.c
 ===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_gre.c    2007-12-15 05:20:06.404205198 +0100
-+++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_gre.c 2007-12-15 05:20:08.708336505 +0100
-@@ -237,16 +237,16 @@
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_gre.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_gre.c
+@@ -237,16 +237,16 @@ static unsigned int gre_print_conntrack(
  /* Returns verdict for packet, and may modify conntrack */
  static int gre_packet(struct ip_conntrack *ct,
                      struct iphdr *iph, size_t len,