[8.09] kernel: refresh patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.4 / patches / 611-netfilter_condition.patch
index c6ffe5b32558987995774a34031af287911f5f6c..de76f876d4c53926e4d0f00227b7fc970c76b8cd 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.4.35.4/Documentation/Configure.help
-===================================================================
---- linux-2.4.35.4.orig/Documentation/Configure.help
-+++ linux-2.4.35.4/Documentation/Configure.help
+--- a/Documentation/Configure.help
++++ b/Documentation/Configure.help
 @@ -2979,6 +2979,14 @@ CONFIG_IP_NF_MATCH_TOS
    If you want to compile it as a module, say M here and read
    <file:Documentation/modules.txt>.  If unsure, say `N'.
@@ -32,10 +30,8 @@ Index: linux-2.4.35.4/Documentation/Configure.help
  Multiple port match support
  CONFIG_IP6_NF_MATCH_MULTIPORT
    Multiport matching allows you to match TCP or UDP packets based on
-Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_condition.h
-===================================================================
 --- /dev/null
-+++ linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_condition.h
++++ b/include/linux/netfilter_ipv4/ipt_condition.h
 @@ -0,0 +1,11 @@
 +#ifndef __IPT_CONDITION_MATCH__
 +#define __IPT_CONDITION_MATCH__
@@ -48,10 +44,8 @@ Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_condition.h
 +};
 +
 +#endif
-Index: linux-2.4.35.4/include/linux/netfilter_ipv6/ip6t_condition.h
-===================================================================
 --- /dev/null
-+++ linux-2.4.35.4/include/linux/netfilter_ipv6/ip6t_condition.h
++++ b/include/linux/netfilter_ipv6/ip6t_condition.h
 @@ -0,0 +1,11 @@
 +#ifndef __IP6T_CONDITION_MATCH__
 +#define __IP6T_CONDITION_MATCH__
@@ -64,10 +58,8 @@ Index: linux-2.4.35.4/include/linux/netfilter_ipv6/ip6t_condition.h
 +};
 +
 +#endif
-Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
-===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/Config.in
-+++ linux-2.4.35.4/net/ipv4/netfilter/Config.in
+--- a/net/ipv4/netfilter/Config.in
++++ b/net/ipv4/netfilter/Config.in
 @@ -43,6 +43,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ]; 
    dep_tristate '  netfilter MARK match support' CONFIG_IP_NF_MATCH_MARK $CONFIG_IP_NF_IPTABLES
    dep_tristate '  Multiple port match support' CONFIG_IP_NF_MATCH_MULTIPORT $CONFIG_IP_NF_IPTABLES
@@ -76,10 +68,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
    dep_tristate '  recent match support' CONFIG_IP_NF_MATCH_RECENT $CONFIG_IP_NF_IPTABLES
    dep_tristate '  ECN match support' CONFIG_IP_NF_MATCH_ECN $CONFIG_IP_NF_IPTABLES
    dep_tristate '  peer to peer traffic match support' CONFIG_IP_NF_MATCH_IPP2P $CONFIG_IP_NF_IPTABLES
-Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.4.35.4/net/ipv4/netfilter/Makefile
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
 @@ -94,6 +94,7 @@ obj-$(CONFIG_IP_NF_MATCH_PKTTYPE) += ipt
  obj-$(CONFIG_IP_NF_MATCH_MULTIPORT) += ipt_multiport.o
  obj-$(CONFIG_IP_NF_MATCH_OWNER) += ipt_owner.o
@@ -88,10 +78,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
  
  obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_recent.o
  
-Index: linux-2.4.35.4/net/ipv4/netfilter/ipt_condition.c
-===================================================================
 --- /dev/null
-+++ linux-2.4.35.4/net/ipv4/netfilter/ipt_condition.c
++++ b/net/ipv4/netfilter/ipt_condition.c
 @@ -0,0 +1,256 @@
 +/*-------------------------------------------*\
 +|          Netfilter Condition Module         |
@@ -349,10 +337,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/ipt_condition.c
 +
 +module_init(init);
 +module_exit(fini);
-Index: linux-2.4.35.4/net/ipv6/netfilter/Config.in
-===================================================================
---- linux-2.4.35.4.orig/net/ipv6/netfilter/Config.in
-+++ linux-2.4.35.4/net/ipv6/netfilter/Config.in
+--- a/net/ipv6/netfilter/Config.in
++++ b/net/ipv6/netfilter/Config.in
 @@ -17,6 +17,7 @@ tristate 'IP6 tables support (required f
  if [ "$CONFIG_IP6_NF_IPTABLES" != "n" ]; then
  # The simple matches.
@@ -361,10 +347,8 @@ Index: linux-2.4.35.4/net/ipv6/netfilter/Config.in
    dep_tristate '  MAC address match support' CONFIG_IP6_NF_MATCH_MAC $CONFIG_IP6_NF_IPTABLES
    if [ "$CONFIG_EXPERIMENTAL" = "y" ]; then
      dep_tristate '  Routing header match support (EXPERIMENTAL)' CONFIG_IP6_NF_MATCH_RT $CONFIG_IP6_NF_IPTABLES
-Index: linux-2.4.35.4/net/ipv6/netfilter/Makefile
-===================================================================
---- linux-2.4.35.4.orig/net/ipv6/netfilter/Makefile
-+++ linux-2.4.35.4/net/ipv6/netfilter/Makefile
+--- a/net/ipv6/netfilter/Makefile
++++ b/net/ipv6/netfilter/Makefile
 @@ -14,6 +14,7 @@ export-objs := ip6_tables.o
  # Link order matters here.
  obj-$(CONFIG_IP6_NF_IPTABLES) += ip6_tables.o
@@ -373,10 +357,8 @@ Index: linux-2.4.35.4/net/ipv6/netfilter/Makefile
  obj-$(CONFIG_IP6_NF_MATCH_MARK) += ip6t_mark.o
  obj-$(CONFIG_IP6_NF_MATCH_LENGTH) += ip6t_length.o
  obj-$(CONFIG_IP6_NF_MATCH_MAC) += ip6t_mac.o
-Index: linux-2.4.35.4/net/ipv6/netfilter/ip6t_condition.c
-===================================================================
 --- /dev/null
-+++ linux-2.4.35.4/net/ipv6/netfilter/ip6t_condition.c
++++ b/net/ipv6/netfilter/ip6t_condition.c
 @@ -0,0 +1,254 @@
 +/*-------------------------------------------*\
 +|    Netfilter Condition Module for IPv6      |