[kernel] generic-2.6/2.6.21: refresh patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.21 / 150-netfilter_imq.patch
index 66fb99bfb13984ada1203b46e9773285a199848a..6ea4f95990d2317ff5c0fd20195203636ec4697b 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.21.7/drivers/net/imq.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.21.7/drivers/net/imq.c
++++ b/drivers/net/imq.c
 @@ -0,0 +1,402 @@
 +/*
 + *             Pseudo-driver for the intermediate queue device.
@@ -405,10 +403,8 @@ Index: linux-2.6.21.7/drivers/net/imq.c
 +MODULE_AUTHOR("http://www.linuximq.net");
 +MODULE_DESCRIPTION("Pseudo-driver for the intermediate queue device. See http://www.linuximq.net/ for more information.");
 +MODULE_LICENSE("GPL");
-Index: linux-2.6.21.7/drivers/net/Kconfig
-===================================================================
---- linux-2.6.21.7.orig/drivers/net/Kconfig
-+++ linux-2.6.21.7/drivers/net/Kconfig
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
 @@ -96,6 +96,129 @@ config EQUALIZER
          To compile this driver as a module, choose M here: the module
          will be called eql.  If unsure, say N.
@@ -539,10 +535,8 @@ Index: linux-2.6.21.7/drivers/net/Kconfig
  config TUN
        tristate "Universal TUN/TAP device driver support"
        select CRC32
-Index: linux-2.6.21.7/drivers/net/Makefile
-===================================================================
---- linux-2.6.21.7.orig/drivers/net/Makefile
-+++ linux-2.6.21.7/drivers/net/Makefile
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
 @@ -124,6 +124,7 @@ obj-$(CONFIG_SLIP) += slip.o
  obj-$(CONFIG_SLHC) += slhc.o
  
@@ -551,10 +545,8 @@ Index: linux-2.6.21.7/drivers/net/Makefile
  obj-$(CONFIG_IFB) += ifb.o
  obj-$(CONFIG_DE600) += de600.o
  obj-$(CONFIG_DE620) += de620.o
-Index: linux-2.6.21.7/include/linux/imq.h
-===================================================================
 --- /dev/null
-+++ linux-2.6.21.7/include/linux/imq.h
++++ b/include/linux/imq.h
 @@ -0,0 +1,9 @@
 +#ifndef _IMQ_H
 +#define _IMQ_H
@@ -565,10 +557,8 @@ Index: linux-2.6.21.7/include/linux/imq.h
 +#define IMQ_F_ENQUEUE  0x80
 +
 +#endif /* _IMQ_H */
-Index: linux-2.6.21.7/include/linux/netfilter_ipv4/ipt_IMQ.h
-===================================================================
 --- /dev/null
-+++ linux-2.6.21.7/include/linux/netfilter_ipv4/ipt_IMQ.h
++++ b/include/linux/netfilter_ipv4/ipt_IMQ.h
 @@ -0,0 +1,8 @@
 +#ifndef _IPT_IMQ_H
 +#define _IPT_IMQ_H
@@ -578,10 +568,8 @@ Index: linux-2.6.21.7/include/linux/netfilter_ipv4/ipt_IMQ.h
 +};
 +
 +#endif /* _IPT_IMQ_H */
-Index: linux-2.6.21.7/include/linux/netfilter_ipv6/ip6t_IMQ.h
-===================================================================
 --- /dev/null
-+++ linux-2.6.21.7/include/linux/netfilter_ipv6/ip6t_IMQ.h
++++ b/include/linux/netfilter_ipv6/ip6t_IMQ.h
 @@ -0,0 +1,8 @@
 +#ifndef _IP6T_IMQ_H
 +#define _IP6T_IMQ_H
@@ -591,10 +579,8 @@ Index: linux-2.6.21.7/include/linux/netfilter_ipv6/ip6t_IMQ.h
 +};
 +
 +#endif /* _IP6T_IMQ_H */
-Index: linux-2.6.21.7/include/linux/skbuff.h
-===================================================================
---- linux-2.6.21.7.orig/include/linux/skbuff.h
-+++ linux-2.6.21.7/include/linux/skbuff.h
+--- a/include/linux/skbuff.h
++++ b/include/linux/skbuff.h
 @@ -294,6 +294,10 @@ struct sk_buff {
  #if defined(CONFIG_NF_CONNTRACK) || defined(CONFIG_NF_CONNTRACK_MODULE)
        struct sk_buff          *nfct_reasm;
@@ -606,10 +592,8 @@ Index: linux-2.6.21.7/include/linux/skbuff.h
  #ifdef CONFIG_BRIDGE_NETFILTER
        struct nf_bridge_info   *nf_bridge;
  #endif
-Index: linux-2.6.21.7/net/core/dev.c
-===================================================================
---- linux-2.6.21.7.orig/net/core/dev.c
-+++ linux-2.6.21.7/net/core/dev.c
+--- a/net/core/dev.c
++++ b/net/core/dev.c
 @@ -94,6 +94,9 @@
  #include <linux/skbuff.h>
  #include <net/sock.h>
@@ -633,10 +617,8 @@ Index: linux-2.6.21.7/net/core/dev.c
                        dev_queue_xmit_nit(skb, dev);
  
                if (netif_needs_gso(dev, skb)) {
-Index: linux-2.6.21.7/net/core/skbuff.c
-===================================================================
---- linux-2.6.21.7.orig/net/core/skbuff.c
-+++ linux-2.6.21.7/net/core/skbuff.c
+--- a/net/core/skbuff.c
++++ b/net/core/skbuff.c
 @@ -430,6 +430,10 @@ struct sk_buff *skb_clone(struct sk_buff
        C(nfct_reasm);
        nf_conntrack_get_reasm(skb->nfct_reasm);
@@ -659,10 +641,8 @@ Index: linux-2.6.21.7/net/core/skbuff.c
  #ifdef CONFIG_BRIDGE_NETFILTER
        new->nf_bridge  = old->nf_bridge;
        nf_bridge_get(old->nf_bridge);
-Index: linux-2.6.21.7/net/ipv4/netfilter/ipt_IMQ.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.21.7/net/ipv4/netfilter/ipt_IMQ.c
++++ b/net/ipv4/netfilter/ipt_IMQ.c
 @@ -0,0 +1,69 @@
 +/*
 + * This target marks packets to be enqueued to an imq device
@@ -733,10 +713,8 @@ Index: linux-2.6.21.7/net/ipv4/netfilter/ipt_IMQ.c
 +MODULE_AUTHOR("http://www.linuximq.net");
 +MODULE_DESCRIPTION("Pseudo-driver for the intermediate queue device. See http://www.linuximq.net/ for more information.");
 +MODULE_LICENSE("GPL");
-Index: linux-2.6.21.7/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.21.7.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.21.7/net/ipv4/netfilter/Kconfig
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
 @@ -587,6 +587,17 @@ config IP_NF_MANGLE
  
          To compile it as a module, choose M here.  If unsure, say N.
@@ -755,10 +733,8 @@ Index: linux-2.6.21.7/net/ipv4/netfilter/Kconfig
  config IP_NF_TARGET_TOS
        tristate "TOS target support"
        depends on IP_NF_MANGLE
-Index: linux-2.6.21.7/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.21.7.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.21.7/net/ipv4/netfilter/Makefile
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
 @@ -99,6 +99,7 @@ obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_i
  obj-$(CONFIG_IP_NF_TARGET_REJECT) += ipt_REJECT.o
  obj-$(CONFIG_IP_NF_TARGET_TOS) += ipt_TOS.o
@@ -767,10 +743,8 @@ Index: linux-2.6.21.7/net/ipv4/netfilter/Makefile
  obj-$(CONFIG_IP_NF_TARGET_MASQUERADE) += ipt_MASQUERADE.o
  obj-$(CONFIG_IP_NF_TARGET_REDIRECT) += ipt_REDIRECT.o
  obj-$(CONFIG_IP_NF_TARGET_NETMAP) += ipt_NETMAP.o
-Index: linux-2.6.21.7/net/ipv6/netfilter/ip6t_IMQ.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.21.7/net/ipv6/netfilter/ip6t_IMQ.c
++++ b/net/ipv6/netfilter/ip6t_IMQ.c
 @@ -0,0 +1,69 @@
 +/*
 + * This target marks packets to be enqueued to an imq device
@@ -841,10 +815,8 @@ Index: linux-2.6.21.7/net/ipv6/netfilter/ip6t_IMQ.c
 +MODULE_AUTHOR("http://www.linuximq.net");
 +MODULE_DESCRIPTION("Pseudo-driver for the intermediate queue device. See http://www.linuximq.net/ for more information.");
 +MODULE_LICENSE("GPL");
-Index: linux-2.6.21.7/net/ipv6/netfilter/Kconfig
-===================================================================
---- linux-2.6.21.7.orig/net/ipv6/netfilter/Kconfig
-+++ linux-2.6.21.7/net/ipv6/netfilter/Kconfig
+--- a/net/ipv6/netfilter/Kconfig
++++ b/net/ipv6/netfilter/Kconfig
 @@ -173,6 +173,15 @@ config IP6_NF_MANGLE
  
          To compile it as a module, choose M here.  If unsure, say N.
@@ -861,10 +833,8 @@ Index: linux-2.6.21.7/net/ipv6/netfilter/Kconfig
  config IP6_NF_TARGET_HL
        tristate  'HL (hoplimit) target support'
        depends on IP6_NF_MANGLE
-Index: linux-2.6.21.7/net/ipv6/netfilter/Makefile
-===================================================================
---- linux-2.6.21.7.orig/net/ipv6/netfilter/Makefile
-+++ linux-2.6.21.7/net/ipv6/netfilter/Makefile
+--- a/net/ipv6/netfilter/Makefile
++++ b/net/ipv6/netfilter/Makefile
 @@ -13,6 +13,7 @@ obj-$(CONFIG_IP6_NF_MATCH_EUI64) += ip6t
  obj-$(CONFIG_IP6_NF_MATCH_OWNER) += ip6t_owner.o
  obj-$(CONFIG_IP6_NF_FILTER) += ip6table_filter.o
@@ -873,10 +843,8 @@ Index: linux-2.6.21.7/net/ipv6/netfilter/Makefile
  obj-$(CONFIG_IP6_NF_TARGET_HL) += ip6t_HL.o
  obj-$(CONFIG_IP6_NF_QUEUE) += ip6_queue.o
  obj-$(CONFIG_IP6_NF_TARGET_LOG) += ip6t_LOG.o
-Index: linux-2.6.21.7/net/sched/sch_generic.c
-===================================================================
---- linux-2.6.21.7.orig/net/sched/sch_generic.c
-+++ linux-2.6.21.7/net/sched/sch_generic.c
+--- a/net/sched/sch_generic.c
++++ b/net/sched/sch_generic.c
 @@ -87,7 +87,6 @@ void qdisc_unlock_tree(struct net_device
  
     NOTE: Called under dev->queue_lock with locally disabled BH.