remove obsolete p54, rt2500 & rt61 since those drivers are built from package/mac8021...
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.23 / 001-squashfs.patch
index 74321331a847a2f98eefd67b7637e8779446a961..6fa0f0cc79edaad0f22a54265a3bfe41d6f8b8e9 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.23/fs/Kconfig
-===================================================================
---- linux-2.6.23.orig/fs/Kconfig       2007-10-10 13:52:12.000000000 +0800
-+++ linux-2.6.23/fs/Kconfig    2007-10-10 13:52:14.000000000 +0800
+--- a/fs/Kconfig
++++ b/fs/Kconfig
 @@ -1364,6 +1364,71 @@
  
          If unsure, say N.
@@ -74,10 +72,8 @@ Index: linux-2.6.23/fs/Kconfig
  config VXFS_FS
        tristate "FreeVxFS file system support (VERITAS VxFS(TM) compatible)"
        depends on BLOCK
-Index: linux-2.6.23/fs/Makefile
-===================================================================
---- linux-2.6.23.orig/fs/Makefile      2007-10-10 13:52:12.000000000 +0800
-+++ linux-2.6.23/fs/Makefile   2007-10-10 13:52:14.000000000 +0800
+--- a/fs/Makefile
++++ b/fs/Makefile
 @@ -72,6 +72,7 @@
  obj-$(CONFIG_JBD2)            += jbd2/
  obj-$(CONFIG_EXT2_FS)         += ext2/
@@ -86,10 +82,8 @@ Index: linux-2.6.23/fs/Makefile
  obj-$(CONFIG_RAMFS)           += ramfs/
  obj-$(CONFIG_HUGETLBFS)               += hugetlbfs/
  obj-$(CONFIG_CODA_FS)         += coda/
-Index: linux-2.6.23/fs/squashfs/inode.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/fs/squashfs/inode.c   2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ b/fs/squashfs/inode.c
 @@ -0,0 +1,2122 @@
 +/*
 + * Squashfs - a compressed read only filesystem for Linux
@@ -2213,10 +2207,8 @@ Index: linux-2.6.23/fs/squashfs/inode.c
 +MODULE_DESCRIPTION("squashfs, a compressed read-only filesystem");
 +MODULE_AUTHOR("Phillip Lougher <phillip@lougher.org.uk>");
 +MODULE_LICENSE("GPL");
-Index: linux-2.6.23/fs/squashfs/Makefile
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/fs/squashfs/Makefile  2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ b/fs/squashfs/Makefile
 @@ -0,0 +1,7 @@
 +#
 +# Makefile for the linux squashfs routines.
@@ -2225,10 +2217,8 @@ Index: linux-2.6.23/fs/squashfs/Makefile
 +obj-$(CONFIG_SQUASHFS) += squashfs.o
 +squashfs-y += inode.o
 +squashfs-y += squashfs2_0.o
-Index: linux-2.6.23/fs/squashfs/squashfs2_0.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/fs/squashfs/squashfs2_0.c     2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ b/fs/squashfs/squashfs2_0.c
 @@ -0,0 +1,758 @@
 +/*
 + * Squashfs - a compressed read only filesystem for Linux
@@ -2988,10 +2978,8 @@ Index: linux-2.6.23/fs/squashfs/squashfs2_0.c
 +
 +      return 1;
 +}
-Index: linux-2.6.23/fs/squashfs/squashfs.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/fs/squashfs/squashfs.h        2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ b/fs/squashfs/squashfs.h
 @@ -0,0 +1,86 @@
 +/*
 + * Squashfs - a compressed read only filesystem for Linux
@@ -3079,10 +3067,8 @@ Index: linux-2.6.23/fs/squashfs/squashfs.h
 +      return 0;
 +}
 +#endif
-Index: linux-2.6.23/include/linux/magic.h
-===================================================================
---- linux-2.6.23.orig/include/linux/magic.h    2007-10-10 13:52:12.000000000 +0800
-+++ linux-2.6.23/include/linux/magic.h 2007-10-10 13:52:14.000000000 +0800
+--- a/include/linux/magic.h
++++ b/include/linux/magic.h
 @@ -35,6 +35,9 @@
  #define REISER2FS_SUPER_MAGIC_STRING  "ReIsEr2Fs"
  #define REISER2FS_JR_SUPER_MAGIC_STRING       "ReIsEr3Fs"
@@ -3093,10 +3079,8 @@ Index: linux-2.6.23/include/linux/magic.h
  #define SMB_SUPER_MAGIC               0x517B
  #define USBDEVICE_SUPER_MAGIC 0x9fa2
  
-Index: linux-2.6.23/include/linux/squashfs_fs.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/squashfs_fs.h   2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ b/include/linux/squashfs_fs.h
 @@ -0,0 +1,911 @@
 +#ifndef SQUASHFS_FS
 +#define SQUASHFS_FS
@@ -4009,10 +3993,8 @@ Index: linux-2.6.23/include/linux/squashfs_fs.h
 +
 +#endif
 +#endif
-Index: linux-2.6.23/include/linux/squashfs_fs_i.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/squashfs_fs_i.h 2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ b/include/linux/squashfs_fs_i.h
 @@ -0,0 +1,45 @@
 +#ifndef SQUASHFS_FS_I
 +#define SQUASHFS_FS_I
@@ -4059,10 +4041,8 @@ Index: linux-2.6.23/include/linux/squashfs_fs_i.h
 +      struct inode    vfs_inode;
 +};
 +#endif
-Index: linux-2.6.23/include/linux/squashfs_fs_sb.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/squashfs_fs_sb.h        2007-10-10 13:52:14.000000000 +0800
+--- /dev/null
++++ b/include/linux/squashfs_fs_sb.h
 @@ -0,0 +1,74 @@
 +#ifndef SQUASHFS_FS_SB
 +#define SQUASHFS_FS_SB
@@ -4138,10 +4118,8 @@ Index: linux-2.6.23/include/linux/squashfs_fs_sb.h
 +      int                     (*read_fragment_index_table)(struct super_block *s);
 +};
 +#endif
-Index: linux-2.6.23/init/do_mounts_rd.c
-===================================================================
---- linux-2.6.23.orig/init/do_mounts_rd.c      2007-10-10 13:52:12.000000000 +0800
-+++ linux-2.6.23/init/do_mounts_rd.c   2007-10-10 13:52:14.000000000 +0800
+--- a/init/do_mounts_rd.c
++++ b/init/do_mounts_rd.c
 @@ -5,6 +5,7 @@
  #include <linux/ext2_fs.h>
  #include <linux/romfs_fs.h>