sync for 2.6.23-final
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.23 / 170-netfilter_chaostables.patch
index ef34ae4793a9dea3f6aeb6790aee33b8f1bd31a2..1c14c13ea88a59f0d682e5428a240dc890397c4a 100644 (file)
@@ -1,17 +1,17 @@
-Index: linux-2.6.23-rc6/include/linux/netfilter/oot_conntrack.h
+Index: linux-2.6.23/include/linux/netfilter/oot_conntrack.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/include/linux/netfilter/oot_conntrack.h   2007-09-21 16:24:03.000000000 +0800
++++ linux-2.6.23/include/linux/netfilter/oot_conntrack.h       2007-10-10 13:52:59.000000000 +0800
 @@ -0,0 +1,5 @@
 +#if defined(CONFIG_IP_NF_CONNTRACK) || defined(CONFIG_IP_NF_CONNTRACK_MODULE)
 +#     include <linux/netfilter_ipv4/ip_conntrack.h>
 +#else /* linux-2.6.20+ */
 +#     include <net/netfilter/nf_nat_rule.h>
 +#endif
 @@ -0,0 +1,5 @@
 +#if defined(CONFIG_IP_NF_CONNTRACK) || defined(CONFIG_IP_NF_CONNTRACK_MODULE)
 +#     include <linux/netfilter_ipv4/ip_conntrack.h>
 +#else /* linux-2.6.20+ */
 +#     include <net/netfilter/nf_nat_rule.h>
 +#endif
-Index: linux-2.6.23-rc6/include/linux/netfilter/oot_trans.h
+Index: linux-2.6.23/include/linux/netfilter/oot_trans.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/include/linux/netfilter/oot_trans.h       2007-09-21 16:24:03.000000000 +0800
++++ linux-2.6.23/include/linux/netfilter/oot_trans.h   2007-10-10 13:52:59.000000000 +0800
 @@ -0,0 +1,14 @@
 +/* Out of tree workarounds */
 +#include <linux/version.h>
 @@ -0,0 +1,14 @@
 +/* Out of tree workarounds */
 +#include <linux/version.h>
@@ -27,10 +27,10 @@ Index: linux-2.6.23-rc6/include/linux/netfilter/oot_trans.h
 +#     define tcp_v4_check(tcph, tcph_sz, s, d, csp) \
 +              tcp_v4_check((tcph_sz), (s), (d), (csp))
 +#endif
 +#     define tcp_v4_check(tcph, tcph_sz, s, d, csp) \
 +              tcp_v4_check((tcph_sz), (s), (d), (csp))
 +#endif
-Index: linux-2.6.23-rc6/include/linux/netfilter/xt_CHAOS.h
+Index: linux-2.6.23/include/linux/netfilter/xt_CHAOS.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/include/linux/netfilter/xt_CHAOS.h        2007-09-21 16:24:03.000000000 +0800
++++ linux-2.6.23/include/linux/netfilter/xt_CHAOS.h    2007-10-10 13:52:59.000000000 +0800
 @@ -0,0 +1,14 @@
 +#ifndef _LINUX_XT_CHAOS_H
 +#define _LINUX_XT_CHAOS_H 1
 @@ -0,0 +1,14 @@
 +#ifndef _LINUX_XT_CHAOS_H
 +#define _LINUX_XT_CHAOS_H 1
@@ -46,10 +46,10 @@ Index: linux-2.6.23-rc6/include/linux/netfilter/xt_CHAOS.h
 +};
 +
 +#endif /* _LINUX_XT_CHAOS_H */
 +};
 +
 +#endif /* _LINUX_XT_CHAOS_H */
-Index: linux-2.6.23-rc6/include/linux/netfilter/xt_portscan.h
+Index: linux-2.6.23/include/linux/netfilter/xt_portscan.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/include/linux/netfilter/xt_portscan.h     2007-09-21 16:24:03.000000000 +0800
++++ linux-2.6.23/include/linux/netfilter/xt_portscan.h 2007-10-10 13:52:59.000000000 +0800
 @@ -0,0 +1,8 @@
 +#ifndef _LINUX_XT_PORTSCAN_H
 +#define _LINUX_XT_PORTSCAN_H 1
 @@ -0,0 +1,8 @@
 +#ifndef _LINUX_XT_PORTSCAN_H
 +#define _LINUX_XT_PORTSCAN_H 1
@@ -59,10 +59,10 @@ Index: linux-2.6.23-rc6/include/linux/netfilter/xt_portscan.h
 +};
 +
 +#endif /* _LINUX_XT_PORTSCAN_H */
 +};
 +
 +#endif /* _LINUX_XT_PORTSCAN_H */
-Index: linux-2.6.23-rc6/net/netfilter/find_match.c
+Index: linux-2.6.23/net/netfilter/find_match.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/net/netfilter/find_match.c        2007-09-21 16:24:03.000000000 +0800
++++ linux-2.6.23/net/netfilter/find_match.c    2007-10-10 13:52:59.000000000 +0800
 @@ -0,0 +1,39 @@
 +/*
 +    xt_request_find_match
 @@ -0,0 +1,39 @@
 +/*
 +    xt_request_find_match
@@ -103,10 +103,10 @@ Index: linux-2.6.23-rc6/net/netfilter/find_match.c
 +
 +/* In case it goes into mainline, let this out-of-tree package compile */
 +#define xt_request_find_match xt_request_find_match_lo
 +
 +/* In case it goes into mainline, let this out-of-tree package compile */
 +#define xt_request_find_match xt_request_find_match_lo
-Index: linux-2.6.23-rc6/net/netfilter/Kconfig
+Index: linux-2.6.23/net/netfilter/Kconfig
 ===================================================================
 ===================================================================
---- linux-2.6.23-rc6.orig/net/netfilter/Kconfig        2007-09-21 16:23:53.000000000 +0800
-+++ linux-2.6.23-rc6/net/netfilter/Kconfig     2007-09-21 16:24:03.000000000 +0800
+--- linux-2.6.23.orig/net/netfilter/Kconfig    2007-10-10 04:31:38.000000000 +0800
++++ linux-2.6.23/net/netfilter/Kconfig 2007-10-10 13:53:04.000000000 +0800
 @@ -265,6 +265,14 @@
  
  # alphabetically ordered list of targets
 @@ -265,6 +265,14 @@
  
  # alphabetically ordered list of targets
@@ -152,10 +152,10 @@ Index: linux-2.6.23-rc6/net/netfilter/Kconfig
  config NETFILTER_XT_MATCH_MULTIPORT
        tristate "Multiple port match support"
        depends on NETFILTER_XTABLES
  config NETFILTER_XT_MATCH_MULTIPORT
        tristate "Multiple port match support"
        depends on NETFILTER_XTABLES
-Index: linux-2.6.23-rc6/net/netfilter/Makefile
+Index: linux-2.6.23/net/netfilter/Makefile
 ===================================================================
 ===================================================================
---- linux-2.6.23-rc6.orig/net/netfilter/Makefile       2007-09-21 16:23:53.000000000 +0800
-+++ linux-2.6.23-rc6/net/netfilter/Makefile    2007-09-21 16:24:03.000000000 +0800
+--- linux-2.6.23.orig/net/netfilter/Makefile   2007-10-10 04:31:38.000000000 +0800
++++ linux-2.6.23/net/netfilter/Makefile        2007-10-10 13:52:59.000000000 +0800
 @@ -38,8 +38,10 @@
  obj-$(CONFIG_NETFILTER_XTABLES) += x_tables.o xt_tcpudp.o
  
 @@ -38,8 +38,10 @@
  obj-$(CONFIG_NETFILTER_XTABLES) += x_tables.o xt_tcpudp.o
  
@@ -175,10 +175,10 @@ Index: linux-2.6.23-rc6/net/netfilter/Makefile
  obj-$(CONFIG_NETFILTER_XT_MATCH_PKTTYPE) += xt_pkttype.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_QUOTA) += xt_quota.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_REALM) += xt_realm.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_PKTTYPE) += xt_pkttype.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_QUOTA) += xt_quota.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_REALM) += xt_realm.o
-Index: linux-2.6.23-rc6/net/netfilter/xt_CHAOS.c
+Index: linux-2.6.23/net/netfilter/xt_CHAOS.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/net/netfilter/xt_CHAOS.c  2007-09-21 16:24:03.000000000 +0800
++++ linux-2.6.23/net/netfilter/xt_CHAOS.c      2007-10-10 13:52:59.000000000 +0800
 @@ -0,0 +1,204 @@
 +/*
 +      CHAOS target for netfilter
 @@ -0,0 +1,204 @@
 +/*
 +      CHAOS target for netfilter
@@ -384,10 +384,10 @@ Index: linux-2.6.23-rc6/net/netfilter/xt_CHAOS.c
 +MODULE_DESCRIPTION("netfilter CHAOS target");
 +MODULE_LICENSE("GPL");
 +MODULE_ALIAS("ipt_CHAOS");
 +MODULE_DESCRIPTION("netfilter CHAOS target");
 +MODULE_LICENSE("GPL");
 +MODULE_ALIAS("ipt_CHAOS");
-Index: linux-2.6.23-rc6/net/netfilter/xt_DELUDE.c
+Index: linux-2.6.23/net/netfilter/xt_DELUDE.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/net/netfilter/xt_DELUDE.c 2007-09-21 16:24:03.000000000 +0800
++++ linux-2.6.23/net/netfilter/xt_DELUDE.c     2007-10-10 13:52:59.000000000 +0800
 @@ -0,0 +1,288 @@
 +/*
 +      DELUDE target
 @@ -0,0 +1,288 @@
 +/*
 +      DELUDE target
@@ -677,10 +677,10 @@ Index: linux-2.6.23-rc6/net/netfilter/xt_DELUDE.c
 +MODULE_DESCRIPTION("netfilter DELUDE target");
 +MODULE_LICENSE("GPL");
 +MODULE_ALIAS("ipt_DELUDE");
 +MODULE_DESCRIPTION("netfilter DELUDE target");
 +MODULE_LICENSE("GPL");
 +MODULE_ALIAS("ipt_DELUDE");
-Index: linux-2.6.23-rc6/net/netfilter/xt_portscan.c
+Index: linux-2.6.23/net/netfilter/xt_portscan.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23-rc6/net/netfilter/xt_portscan.c       2007-09-21 16:24:03.000000000 +0800
++++ linux-2.6.23/net/netfilter/xt_portscan.c   2007-10-10 13:52:59.000000000 +0800
 @@ -0,0 +1,272 @@
 +/*
 +      portscan match for netfilter
 @@ -0,0 +1,272 @@
 +/*
 +      portscan match for netfilter
@@ -954,11 +954,11 @@ Index: linux-2.6.23-rc6/net/netfilter/xt_portscan.c
 +MODULE_DESCRIPTION("netfilter portscan match module");
 +MODULE_LICENSE("GPL");
 +MODULE_ALIAS("ipt_portscan");
 +MODULE_DESCRIPTION("netfilter portscan match module");
 +MODULE_LICENSE("GPL");
 +MODULE_ALIAS("ipt_portscan");
-Index: linux-2.6.23-rc6/drivers/char/random.c
+Index: linux-2.6.23/drivers/char/random.c
 ===================================================================
 ===================================================================
---- linux-2.6.23-rc6.orig/drivers/char/random.c        2007-09-21 16:23:53.000000000 +0800
-+++ linux-2.6.23-rc6/drivers/char/random.c     2007-09-21 16:24:03.000000000 +0800
-@@ -1562,6 +1562,8 @@
+--- linux-2.6.23.orig/drivers/char/random.c    2007-10-10 04:31:38.000000000 +0800
++++ linux-2.6.23/drivers/char/random.c 2007-10-10 13:52:59.000000000 +0800
+@@ -1564,6 +1564,8 @@
        return seq;
  }
  
        return seq;
  }