remove more redundant files and clone files-2.6.23 for 2.6.24 - fixes rdc build errors
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.23 / 640-mvswitch.patch
index 15c6e481ff5d73d2e539a4d503037ea0cc201f99..ba628326cbaa140079481cfa3e3aa9654a387ac8 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.23.16/drivers/net/phy/Kconfig
-===================================================================
---- linux-2.6.23.16.orig/drivers/net/phy/Kconfig       2008-04-20 07:31:20.000000000 +0200
-+++ linux-2.6.23.16/drivers/net/phy/Kconfig    2008-04-20 08:57:26.000000000 +0200
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
 @@ -65,6 +65,12 @@
        ---help---
          Currently supports the ADM6996F switch
@@ -15,20 +13,16 @@ Index: linux-2.6.23.16/drivers/net/phy/Kconfig
  config FIXED_PHY
        tristate "Drivers for PHY emulation on fixed speed/link"
        ---help---
-Index: linux-2.6.23.16/drivers/net/phy/Makefile
-===================================================================
---- linux-2.6.23.16.orig/drivers/net/phy/Makefile      2008-04-20 07:31:20.000000000 +0200
-+++ linux-2.6.23.16/drivers/net/phy/Makefile   2008-04-20 07:31:34.000000000 +0200
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
 @@ -13,4 +13,5 @@
  obj-$(CONFIG_BROADCOM_PHY)    += broadcom.o
  obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
  obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
 +obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o
-Index: linux-2.6.23.16/drivers/net/phy/mdio_bus.c
-===================================================================
---- linux-2.6.23.16.orig/drivers/net/phy/mdio_bus.c    2008-04-20 04:40:31.000000000 +0200
-+++ linux-2.6.23.16/drivers/net/phy/mdio_bus.c 2008-04-20 07:34:08.000000000 +0200
+--- a/drivers/net/phy/mdio_bus.c
++++ b/drivers/net/phy/mdio_bus.c
 @@ -35,6 +35,12 @@
  #include <asm/irq.h>
  #include <asm/uaccess.h>