remove more redundant files and clone files-2.6.23 for 2.6.24 - fixes rdc build errors
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.23 / 640-mvswitch.patch
index 7b88397063d53782d0b52d9bbdd2226ea6c3277a..ba628326cbaa140079481cfa3e3aa9654a387ac8 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.23.17/drivers/net/phy/Kconfig
-===================================================================
---- linux-2.6.23.17.orig/drivers/net/phy/Kconfig
-+++ linux-2.6.23.17/drivers/net/phy/Kconfig
-@@ -65,6 +65,12 @@ config ADM6996_PHY
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -65,6 +65,12 @@
        ---help---
          Currently supports the ADM6996F switch
  
@@ -15,20 +13,16 @@ Index: linux-2.6.23.17/drivers/net/phy/Kconfig
  config FIXED_PHY
        tristate "Drivers for PHY emulation on fixed speed/link"
        ---help---
-Index: linux-2.6.23.17/drivers/net/phy/Makefile
-===================================================================
---- linux-2.6.23.17.orig/drivers/net/phy/Makefile
-+++ linux-2.6.23.17/drivers/net/phy/Makefile
-@@ -13,4 +13,5 @@ obj-$(CONFIG_VITESSE_PHY)    += vitesse.o
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -13,4 +13,5 @@
  obj-$(CONFIG_BROADCOM_PHY)    += broadcom.o
  obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
  obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
 +obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o
-Index: linux-2.6.23.17/drivers/net/phy/mdio_bus.c
-===================================================================
---- linux-2.6.23.17.orig/drivers/net/phy/mdio_bus.c
-+++ linux-2.6.23.17/drivers/net/phy/mdio_bus.c
+--- a/drivers/net/phy/mdio_bus.c
++++ b/drivers/net/phy/mdio_bus.c
 @@ -35,6 +35,12 @@
  #include <asm/irq.h>
  #include <asm/uaccess.h>
@@ -42,7 +36,7 @@ Index: linux-2.6.23.17/drivers/net/phy/mdio_bus.c
  /**
   * mdiobus_register - bring up all the PHYs on a given bus and attach them to bus
   * @bus: target mii_bus
-@@ -85,6 +91,7 @@ int mdiobus_register(struct mii_bus *bus
+@@ -85,6 +91,7 @@
  
                        phydev->dev.parent = bus->dev;
                        phydev->dev.bus = &mdio_bus_type;