[kernel] refresh generic 2.6.23 patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.23 / 922-w1_gpio_driver_backport.patch
index 43d73d0bfa986a89f2c4e55035dc45e4cd3ddbaa..4a66308ece74e46962d60be5bc7759165e1f7d13 100644 (file)
@@ -1,7 +1,7 @@
-Index: linux-2.6.24.5/drivers/w1/masters/Kconfig
+Index: linux-2.6.23.17/drivers/w1/masters/Kconfig
 ===================================================================
---- linux-2.6.23.16.orig/drivers/w1/masters/Kconfig
-+++ linux-2.6.23.16/drivers/w1/masters/Kconfig
+--- linux-2.6.23.17.orig/drivers/w1/masters/Kconfig
++++ linux-2.6.23.17/drivers/w1/masters/Kconfig
 @@ -42,5 +42,15 @@ config W1_MASTER_DS1WM
          in HP iPAQ devices like h5xxx, h2200, and ASIC3-based like
          hx4700.
@@ -18,19 +18,19 @@ Index: linux-2.6.24.5/drivers/w1/masters/Kconfig
 +
  endmenu
  
-Index: linux-2.6.23.16/drivers/w1/masters/Makefile
+Index: linux-2.6.23.17/drivers/w1/masters/Makefile
 ===================================================================
---- linux-2.6.23.16.orig/drivers/w1/masters/Makefile
-+++ linux-2.6.23.16/drivers/w1/masters/Makefile
+--- linux-2.6.23.17.orig/drivers/w1/masters/Makefile
++++ linux-2.6.23.17/drivers/w1/masters/Makefile
 @@ -6,3 +6,4 @@ obj-$(CONFIG_W1_MASTER_MATROX)         += matro
  obj-$(CONFIG_W1_MASTER_DS2490)                += ds2490.o
  obj-$(CONFIG_W1_MASTER_DS2482)                += ds2482.o
  obj-$(CONFIG_W1_MASTER_DS1WM)         += ds1wm.o
 +obj-$(CONFIG_W1_MASTER_GPIO)          += w1-gpio.o
-Index: linux-2.6.23.16/drivers/w1/masters/w1-gpio.c
+Index: linux-2.6.23.17/drivers/w1/masters/w1-gpio.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.23.16/drivers/w1/masters/w1-gpio.c
++++ linux-2.6.23.17/drivers/w1/masters/w1-gpio.c
 @@ -0,0 +1,124 @@
 +/*
 + * w1-gpio - GPIO w1 bus master driver
@@ -156,10 +156,10 @@ Index: linux-2.6.23.16/drivers/w1/masters/w1-gpio.c
 +MODULE_DESCRIPTION("GPIO w1 bus master driver");
 +MODULE_AUTHOR("Ville Syrjala <syrjala@sci.fi>");
 +MODULE_LICENSE("GPL");
-Index: linux-2.6.23.16/include/linux/w1-gpio.h
+Index: linux-2.6.23.17/include/linux/w1-gpio.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.23.16/include/linux/w1-gpio.h
++++ linux-2.6.23.17/include/linux/w1-gpio.h
 @@ -0,0 +1,23 @@
 +/*
 + * w1-gpio interface to platform code