refresh generic 2.6.24 patches to match upstream style
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.24 / 190-netfilter_rtsp.patch
index e44dc9cf138a13ebb1abdbf13e0569817ece3cb9..6e6abc73aff673f5311c4dd77b02e6a6d5d00a2c 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.24.7/include/linux/netfilter/nf_conntrack_rtsp.h
-===================================================================
 --- /dev/null
-+++ linux-2.6.24.7/include/linux/netfilter/nf_conntrack_rtsp.h
++++ b/include/linux/netfilter/nf_conntrack_rtsp.h
 @@ -0,0 +1,63 @@
 +/*
 + * RTSP extension for IP connection tracking.
@@ -66,10 +64,8 @@ Index: linux-2.6.24.7/include/linux/netfilter/nf_conntrack_rtsp.h
 +#endif /* __KERNEL__ */
 +
 +#endif /* _IP_CONNTRACK_RTSP_H */
-Index: linux-2.6.24.7/include/linux/netfilter_helpers.h
-===================================================================
 --- /dev/null
-+++ linux-2.6.24.7/include/linux/netfilter_helpers.h
++++ b/include/linux/netfilter_helpers.h
 @@ -0,0 +1,133 @@
 +/*
 + * Helpers for netfiler modules.  This file provides implementations for basic
@@ -204,10 +200,8 @@ Index: linux-2.6.24.7/include/linux/netfilter_helpers.h
 +#endif /* __KERNEL__ */
 +
 +#endif /* _NETFILTER_HELPERS_H */
-Index: linux-2.6.24.7/include/linux/netfilter_mime.h
-===================================================================
 --- /dev/null
-+++ linux-2.6.24.7/include/linux/netfilter_mime.h
++++ b/include/linux/netfilter_mime.h
 @@ -0,0 +1,89 @@
 +/*
 + * MIME functions for netfilter modules.  This file provides implementations
@@ -298,11 +292,9 @@ Index: linux-2.6.24.7/include/linux/netfilter_mime.h
 +#endif /* __KERNEL__ */
 +
 +#endif /* _NETFILTER_MIME_H */
-Index: linux-2.6.24.7/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.24.7.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.24.7/net/ipv4/netfilter/Makefile
-@@ -23,6 +23,7 @@ obj-$(CONFIG_NF_NAT_AMANDA) += nf_nat_am
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -23,6 +23,7 @@
  obj-$(CONFIG_NF_NAT_FTP) += nf_nat_ftp.o
  obj-$(CONFIG_NF_NAT_H323) += nf_nat_h323.o
  obj-$(CONFIG_NF_NAT_IRC) += nf_nat_irc.o
@@ -310,11 +302,9 @@ Index: linux-2.6.24.7/net/ipv4/netfilter/Makefile
  obj-$(CONFIG_NF_NAT_PPTP) += nf_nat_pptp.o
  obj-$(CONFIG_NF_NAT_SIP) += nf_nat_sip.o
  obj-$(CONFIG_NF_NAT_SNMP_BASIC) += nf_nat_snmp_basic.o
-Index: linux-2.6.24.7/net/netfilter/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/net/netfilter/Kconfig
-+++ linux-2.6.24.7/net/netfilter/Kconfig
-@@ -249,6 +249,16 @@ config NF_CONNTRACK_TFTP
+--- a/net/netfilter/Kconfig
++++ b/net/netfilter/Kconfig
+@@ -249,6 +249,16 @@
  
          To compile it as a module, choose M here.  If unsure, say N.
  
@@ -331,11 +321,9 @@ Index: linux-2.6.24.7/net/netfilter/Kconfig
  config NF_CT_NETLINK
        tristate 'Connection tracking netlink interface (EXPERIMENTAL)'
        depends on EXPERIMENTAL && NF_CONNTRACK && NETFILTER_NETLINK
-Index: linux-2.6.24.7/net/netfilter/Makefile
-===================================================================
---- linux-2.6.24.7.orig/net/netfilter/Makefile
-+++ linux-2.6.24.7/net/netfilter/Makefile
-@@ -33,6 +33,7 @@ obj-$(CONFIG_NF_CONNTRACK_PPTP) += nf_co
+--- a/net/netfilter/Makefile
++++ b/net/netfilter/Makefile
+@@ -33,6 +33,7 @@
  obj-$(CONFIG_NF_CONNTRACK_SANE) += nf_conntrack_sane.o
  obj-$(CONFIG_NF_CONNTRACK_SIP) += nf_conntrack_sip.o
  obj-$(CONFIG_NF_CONNTRACK_TFTP) += nf_conntrack_tftp.o
@@ -343,11 +331,9 @@ Index: linux-2.6.24.7/net/netfilter/Makefile
  
  # generic X tables 
  obj-$(CONFIG_NETFILTER_XTABLES) += x_tables.o xt_tcpudp.o
-Index: linux-2.6.24.7/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.24.7/net/ipv4/netfilter/Kconfig
-@@ -296,6 +296,11 @@ config NF_NAT_IRC
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
+@@ -296,6 +296,11 @@
        depends on IP_NF_IPTABLES && NF_CONNTRACK && NF_NAT
        default NF_NAT && NF_CONNTRACK_IRC
  
@@ -359,10 +345,8 @@ Index: linux-2.6.24.7/net/ipv4/netfilter/Kconfig
  config NF_NAT_TFTP
        tristate
        depends on IP_NF_IPTABLES && NF_CONNTRACK && NF_NAT
-Index: linux-2.6.24.7/net/netfilter/nf_conntrack_rtsp.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.24.7/net/netfilter/nf_conntrack_rtsp.c
++++ b/net/netfilter/nf_conntrack_rtsp.c
 @@ -0,0 +1,513 @@
 +/*
 + * RTSP extension for IP connection tracking
@@ -877,10 +861,8 @@ Index: linux-2.6.24.7/net/netfilter/nf_conntrack_rtsp.c
 +
 +EXPORT_SYMBOL(nf_nat_rtsp_hook_expectfn);
 +
-Index: linux-2.6.24.7/net/ipv4/netfilter/nf_nat_rtsp.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.24.7/net/ipv4/netfilter/nf_nat_rtsp.c
++++ b/net/ipv4/netfilter/nf_nat_rtsp.c
 @@ -0,0 +1,496 @@
 +/*
 + * RTSP extension for TCP NAT alteration