refresh generic 2.6.25 patches to match upstream style
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.25 / 002-lzma_decompress.patch
index 73cf22a9b4f4e2bc213f5de9ab6d29ed53180b47..fdc30398631adbbebb9f27b63483a931cb362a74 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.25.4/include/linux/LzmaDecode.h
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/include/linux/LzmaDecode.h
++++ b/include/linux/LzmaDecode.h
 @@ -0,0 +1,100 @@
 +/*
 +  LzmaDecode.h
@@ -103,10 +101,8 @@ Index: linux-2.6.25.4/include/linux/LzmaDecode.h
 +    UInt32 *outSizeProcessed);
 +
 +#endif
-Index: linux-2.6.25.4/lib/LzmaDecode.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/lib/LzmaDecode.c
++++ b/lib/LzmaDecode.c
 @@ -0,0 +1,663 @@
 +/*
 +  LzmaDecode.c
@@ -771,11 +767,9 @@ Index: linux-2.6.25.4/lib/LzmaDecode.c
 +  *outSizeProcessed = nowPos;
 +  return LZMA_RESULT_OK;
 +}
-Index: linux-2.6.25.4/lib/Makefile
-===================================================================
---- linux-2.6.25.4.orig/lib/Makefile
-+++ linux-2.6.25.4/lib/Makefile
-@@ -14,7 +14,7 @@ lib-$(CONFIG_SMP) += cpumask.o
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -14,7 +14,7 @@
  lib-y += kobject.o kref.o klist.o
  
  obj-y += div64.o sort.o parser.o halfmd4.o debug_locks.o random32.o \