[kernel] refresh generic 2.6.25 patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.25 / 130-netfilter_ipset.patch
index 24c0e71f9791eaabbdfac8e634b5eb0bd39c7790..294210ba37dc63d12b6ed67eb5832de9357736ce 100644 (file)
@@ -1,7 +1,7 @@
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set.h
 @@ -0,0 +1,498 @@
 +#ifndef _IP_SET_H
 +#define _IP_SET_H
@@ -501,10 +501,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set.h
 +#endif                                /* __KERNEL__ */
 +
 +#endif /*_IP_SET_H*/
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_iphash.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_iphash.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_iphash.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_iphash.h
 @@ -0,0 +1,30 @@
 +#ifndef __IP_SET_IPHASH_H
 +#define __IP_SET_IPHASH_H
@@ -536,10 +536,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_iphash.h
 +};
 +
 +#endif        /* __IP_SET_IPHASH_H */
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_ipmap.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_ipmap.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_ipmap.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_ipmap.h
 @@ -0,0 +1,56 @@
 +#ifndef __IP_SET_IPMAP_H
 +#define __IP_SET_IPMAP_H
@@ -597,10 +597,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_ipmap.h
 +}
 +      
 +#endif /* __IP_SET_IPMAP_H */
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_ipporthash.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_ipporthash.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_ipporthash.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_ipporthash.h
 @@ -0,0 +1,34 @@
 +#ifndef __IP_SET_IPPORTHASH_H
 +#define __IP_SET_IPPORTHASH_H
@@ -636,10 +636,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_ipporthash.h
 +};
 +
 +#endif        /* __IP_SET_IPPORTHASH_H */
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_iptree.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_iptree.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_iptree.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_iptree.h
 @@ -0,0 +1,40 @@
 +#ifndef __IP_SET_IPTREE_H
 +#define __IP_SET_IPTREE_H
@@ -681,10 +681,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_iptree.h
 +};
 +
 +#endif        /* __IP_SET_IPTREE_H */
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_iptreemap.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_iptreemap.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_iptreemap.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_iptreemap.h
 @@ -0,0 +1,40 @@
 +#ifndef __IP_SET_IPTREEMAP_H
 +#define __IP_SET_IPTREEMAP_H
@@ -726,10 +726,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_iptreemap.h
 +};
 +
 +#endif /* __IP_SET_IPTREEMAP_H */
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_jhash.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_jhash.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_jhash.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_jhash.h
 @@ -0,0 +1,148 @@
 +#ifndef _LINUX_IPSET_JHASH_H
 +#define _LINUX_IPSET_JHASH_H
@@ -879,10 +879,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_jhash.h
 +}
 +
 +#endif /* _LINUX_IPSET_JHASH_H */
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_macipmap.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_macipmap.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_macipmap.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_macipmap.h
 @@ -0,0 +1,38 @@
 +#ifndef __IP_SET_MACIPMAP_H
 +#define __IP_SET_MACIPMAP_H
@@ -922,10 +922,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_macipmap.h
 +};
 +
 +#endif        /* __IP_SET_MACIPMAP_H */
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_malloc.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_malloc.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_malloc.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_malloc.h
 @@ -0,0 +1,116 @@
 +#ifndef _IP_SET_MALLOC_H
 +#define _IP_SET_MALLOC_H
@@ -1043,10 +1043,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_malloc.h
 +#endif                                /* __KERNEL__ */
 +
 +#endif /*_IP_SET_MALLOC_H*/
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_nethash.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_nethash.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_nethash.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_nethash.h
 @@ -0,0 +1,55 @@
 +#ifndef __IP_SET_NETHASH_H
 +#define __IP_SET_NETHASH_H
@@ -1103,10 +1103,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_nethash.h
 +}
 +
 +#endif        /* __IP_SET_NETHASH_H */
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_portmap.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_portmap.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_portmap.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ip_set_portmap.h
 @@ -0,0 +1,25 @@
 +#ifndef __IP_SET_PORTMAP_H
 +#define __IP_SET_PORTMAP_H
@@ -1133,10 +1133,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ip_set_portmap.h
 +};
 +
 +#endif /* __IP_SET_PORTMAP_H */
-Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ipt_set.h
+Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ipt_set.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/netfilter_ipv4/ipt_set.h
++++ linux-2.6.25.4/include/linux/netfilter_ipv4/ipt_set.h
 @@ -0,0 +1,21 @@
 +#ifndef _IPT_SET_H
 +#define _IPT_SET_H
@@ -1159,10 +1159,10 @@ Index: linux-2.6.25.1/include/linux/netfilter_ipv4/ipt_set.h
 +};
 +
 +#endif /*_IPT_SET_H*/
-Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set.c
+Index: linux-2.6.25.4/net/ipv4/netfilter/ip_set.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/net/ipv4/netfilter/ip_set.c
++++ linux-2.6.25.4/net/ipv4/netfilter/ip_set.c
 @@ -0,0 +1,2003 @@
 +/* Copyright (C) 2000-2002 Joakim Axelsson <gozem@linux.nu>
 + *                         Patrick Schaaf <bof@bof.de>
@@ -3167,10 +3167,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set.c
 +
 +module_init(ip_set_init);
 +module_exit(ip_set_fini);
-Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_iphash.c
+Index: linux-2.6.25.4/net/ipv4/netfilter/ip_set_iphash.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/net/ipv4/netfilter/ip_set_iphash.c
++++ linux-2.6.25.4/net/ipv4/netfilter/ip_set_iphash.c
 @@ -0,0 +1,429 @@
 +/* Copyright (C) 2003-2004 Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
 + *
@@ -3601,10 +3601,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_iphash.c
 +
 +module_init(ip_set_iphash_init);
 +module_exit(ip_set_iphash_fini);
-Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_ipmap.c
+Index: linux-2.6.25.4/net/ipv4/netfilter/ip_set_ipmap.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/net/ipv4/netfilter/ip_set_ipmap.c
++++ linux-2.6.25.4/net/ipv4/netfilter/ip_set_ipmap.c
 @@ -0,0 +1,336 @@
 +/* Copyright (C) 2000-2002 Joakim Axelsson <gozem@linux.nu>
 + *                         Patrick Schaaf <bof@bof.de>
@@ -3942,10 +3942,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_ipmap.c
 +
 +module_init(ip_set_ipmap_init);
 +module_exit(ip_set_ipmap_fini);
-Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_ipporthash.c
+Index: linux-2.6.25.4/net/ipv4/netfilter/ip_set_ipporthash.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/net/ipv4/netfilter/ip_set_ipporthash.c
++++ linux-2.6.25.4/net/ipv4/netfilter/ip_set_ipporthash.c
 @@ -0,0 +1,581 @@
 +/* Copyright (C) 2003-2004 Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
 + *
@@ -4528,10 +4528,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_ipporthash.c
 +
 +module_init(ip_set_ipporthash_init);
 +module_exit(ip_set_ipporthash_fini);
-Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_iptree.c
+Index: linux-2.6.25.4/net/ipv4/netfilter/ip_set_iptree.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/net/ipv4/netfilter/ip_set_iptree.c
++++ linux-2.6.25.4/net/ipv4/netfilter/ip_set_iptree.c
 @@ -0,0 +1,612 @@
 +/* Copyright (C) 2005 Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
 + *
@@ -5145,10 +5145,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_iptree.c
 +
 +module_init(ip_set_iptree_init);
 +module_exit(ip_set_iptree_fini);
-Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_iptreemap.c
+Index: linux-2.6.25.4/net/ipv4/netfilter/ip_set_iptreemap.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/net/ipv4/netfilter/ip_set_iptreemap.c
++++ linux-2.6.25.4/net/ipv4/netfilter/ip_set_iptreemap.c
 @@ -0,0 +1,829 @@
 +/* Copyright (C) 2007 Sven Wegener <sven.wegener@stealer.net>
 + *
@@ -5979,10 +5979,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_iptreemap.c
 +
 +module_init(ip_set_iptreemap_init);
 +module_exit(ip_set_iptreemap_fini);
-Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_macipmap.c
+Index: linux-2.6.25.4/net/ipv4/netfilter/ip_set_macipmap.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/net/ipv4/netfilter/ip_set_macipmap.c
++++ linux-2.6.25.4/net/ipv4/netfilter/ip_set_macipmap.c
 @@ -0,0 +1,375 @@
 +/* Copyright (C) 2000-2002 Joakim Axelsson <gozem@linux.nu>
 + *                         Patrick Schaaf <bof@bof.de>
@@ -6359,10 +6359,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_macipmap.c
 +
 +module_init(ip_set_macipmap_init);
 +module_exit(ip_set_macipmap_fini);
-Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_nethash.c
+Index: linux-2.6.25.4/net/ipv4/netfilter/ip_set_nethash.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/net/ipv4/netfilter/ip_set_nethash.c
++++ linux-2.6.25.4/net/ipv4/netfilter/ip_set_nethash.c
 @@ -0,0 +1,497 @@
 +/* Copyright (C) 2003-2004 Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
 + *
@@ -6861,10 +6861,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_nethash.c
 +
 +module_init(ip_set_nethash_init);
 +module_exit(ip_set_nethash_fini);
-Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_portmap.c
+Index: linux-2.6.25.4/net/ipv4/netfilter/ip_set_portmap.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/net/ipv4/netfilter/ip_set_portmap.c
++++ linux-2.6.25.4/net/ipv4/netfilter/ip_set_portmap.c
 @@ -0,0 +1,346 @@
 +/* Copyright (C) 2003-2004 Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
 + *
@@ -7212,10 +7212,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/ip_set_portmap.c
 +
 +module_init(ip_set_portmap_init);
 +module_exit(ip_set_portmap_fini);
-Index: linux-2.6.25.1/net/ipv4/netfilter/ipt_set.c
+Index: linux-2.6.25.4/net/ipv4/netfilter/ipt_set.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/net/ipv4/netfilter/ipt_set.c
++++ linux-2.6.25.4/net/ipv4/netfilter/ipt_set.c
 @@ -0,0 +1,160 @@
 +/* Copyright (C) 2000-2002 Joakim Axelsson <gozem@linux.nu>
 + *                         Patrick Schaaf <bof@bof.de>
@@ -7377,10 +7377,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/ipt_set.c
 +
 +module_init(ipt_ipset_init);
 +module_exit(ipt_ipset_fini);
-Index: linux-2.6.25.1/net/ipv4/netfilter/ipt_SET.c
+Index: linux-2.6.25.4/net/ipv4/netfilter/ipt_SET.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/net/ipv4/netfilter/ipt_SET.c
++++ linux-2.6.25.4/net/ipv4/netfilter/ipt_SET.c
 @@ -0,0 +1,179 @@
 +/* Copyright (C) 2000-2002 Joakim Axelsson <gozem@linux.nu>
 + *                         Patrick Schaaf <bof@bof.de>
@@ -7561,10 +7561,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/ipt_SET.c
 +
 +module_init(ipt_SET_init);
 +module_exit(ipt_SET_fini);
-Index: linux-2.6.25.1/net/ipv4/netfilter/Kconfig
+Index: linux-2.6.25.4/net/ipv4/netfilter/Kconfig
 ===================================================================
---- linux-2.6.25.1.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.25.1/net/ipv4/netfilter/Kconfig
+--- linux-2.6.25.4.orig/net/ipv4/netfilter/Kconfig
++++ linux-2.6.25.4/net/ipv4/netfilter/Kconfig
 @@ -385,5 +385,122 @@ config IP_NF_ARP_MANGLE
          Allows altering the ARP packet payload: source and destination
          hardware and network addresses.
@@ -7688,10 +7688,10 @@ Index: linux-2.6.25.1/net/ipv4/netfilter/Kconfig
 +
  endmenu
  
-Index: linux-2.6.25.1/net/ipv4/netfilter/Makefile
+Index: linux-2.6.25.4/net/ipv4/netfilter/Makefile
 ===================================================================
---- linux-2.6.25.1.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.25.1/net/ipv4/netfilter/Makefile
+--- linux-2.6.25.4.orig/net/ipv4/netfilter/Makefile
++++ linux-2.6.25.4/net/ipv4/netfilter/Makefile
 @@ -46,6 +46,7 @@ obj-$(CONFIG_IP_NF_MATCH_AH) += ipt_ah.o
  obj-$(CONFIG_IP_NF_MATCH_ECN) += ipt_ecn.o
  obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_recent.o