refresh generic 2.6.25 patches to match upstream style
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.25 / 171-netfilter_tarpit.patch
index 7add5f5b93219d118ab4d4aa6f1b4ffbecca3780..8575368699702a08f7d5f8834cbbece52e4e430f 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.25.4/net/netfilter/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/net/netfilter/Kconfig
-+++ linux-2.6.25.4/net/netfilter/Kconfig
-@@ -437,6 +437,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
+--- a/net/netfilter/Kconfig
++++ b/net/netfilter/Kconfig
+@@ -437,6 +437,23 @@
  
          To compile it as a module, choose M here.  If unsure, say N.
  
@@ -26,11 +24,9 @@ Index: linux-2.6.25.4/net/netfilter/Kconfig
  config NETFILTER_XT_TARGET_TCPMSS
        tristate '"TCPMSS" target support'
        depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.25.4/net/netfilter/Makefile
-===================================================================
---- linux-2.6.25.4.orig/net/netfilter/Makefile
-+++ linux-2.6.25.4/net/netfilter/Makefile
-@@ -47,6 +47,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFQUEUE
+--- a/net/netfilter/Makefile
++++ b/net/netfilter/Makefile
+@@ -47,6 +47,7 @@
  obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_RATEEST) += xt_RATEEST.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_SECMARK) += xt_SECMARK.o
@@ -38,10 +34,8 @@ Index: linux-2.6.25.4/net/netfilter/Makefile
  obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_TCPOPTSTRIP) += xt_TCPOPTSTRIP.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_TRACE) += xt_TRACE.o
-Index: linux-2.6.25.4/net/netfilter/xt_TARPIT.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/net/netfilter/xt_TARPIT.c
++++ b/net/netfilter/xt_TARPIT.c
 @@ -0,0 +1,279 @@
 +/*
 + * Kernel module to capture and hold incoming TCP connections using