[kernel] refresh generic 2.6.25 patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.25 / 200-sched_esfq.patch
index 142c82ab181a1f20391324adb488f3562a4a3c0d..ac39a8c72f3224f10cbaf4e47551b91a49441384 100644 (file)
@@ -1,7 +1,7 @@
-Index: linux-2.6.25.1/include/linux/pkt_sched.h
+Index: linux-2.6.25.4/include/linux/pkt_sched.h
 ===================================================================
---- linux-2.6.25.1.orig/include/linux/pkt_sched.h
-+++ linux-2.6.25.1/include/linux/pkt_sched.h
+--- linux-2.6.25.4.orig/include/linux/pkt_sched.h
++++ linux-2.6.25.4/include/linux/pkt_sched.h
 @@ -162,8 +162,37 @@ struct tc_sfq_xstats
   *
   *    The only reason for this is efficiency, it is possible
@@ -40,10 +40,10 @@ Index: linux-2.6.25.1/include/linux/pkt_sched.h
  /* RED section */
  
  enum
-Index: linux-2.6.25.1/net/sched/Kconfig
+Index: linux-2.6.25.4/net/sched/Kconfig
 ===================================================================
---- linux-2.6.25.1.orig/net/sched/Kconfig
-+++ linux-2.6.25.1/net/sched/Kconfig
+--- linux-2.6.25.4.orig/net/sched/Kconfig
++++ linux-2.6.25.4/net/sched/Kconfig
 @@ -139,6 +139,37 @@ config NET_SCH_SFQ
          To compile this code as a module, choose M here: the
          module will be called sch_sfq.
@@ -82,10 +82,10 @@ Index: linux-2.6.25.1/net/sched/Kconfig
  config NET_SCH_TEQL
        tristate "True Link Equalizer (TEQL)"
        ---help---
-Index: linux-2.6.25.1/net/sched/Makefile
+Index: linux-2.6.25.4/net/sched/Makefile
 ===================================================================
---- linux-2.6.25.1.orig/net/sched/Makefile
-+++ linux-2.6.25.1/net/sched/Makefile
+--- linux-2.6.25.4.orig/net/sched/Makefile
++++ linux-2.6.25.4/net/sched/Makefile
 @@ -23,6 +23,7 @@ obj-$(CONFIG_NET_SCH_GRED)   += sch_gred.o
  obj-$(CONFIG_NET_SCH_INGRESS) += sch_ingress.o 
  obj-$(CONFIG_NET_SCH_DSMARK)  += sch_dsmark.o
@@ -94,10 +94,10 @@ Index: linux-2.6.25.1/net/sched/Makefile
  obj-$(CONFIG_NET_SCH_TBF)     += sch_tbf.o
  obj-$(CONFIG_NET_SCH_TEQL)    += sch_teql.o
  obj-$(CONFIG_NET_SCH_PRIO)    += sch_prio.o
-Index: linux-2.6.25.1/net/sched/sch_esfq.c
+Index: linux-2.6.25.4/net/sched/sch_esfq.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/net/sched/sch_esfq.c
++++ linux-2.6.25.4/net/sched/sch_esfq.c
 @@ -0,0 +1,702 @@
 +/*
 + * net/sched/sch_esfq.c       Extended Stochastic Fairness Queueing discipline.