[kernel] mode cygwin fixes for scripts/mod/file2alias
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.25 / 902-darwin_scripts_include.patch
index 68f1f7afb9dda1a2a641d6988034cf35a0b2e0e2..88c0421f03ca1c86d13248acc3b6c2857e1b1367 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.25.1/scripts/genksyms/parse.c_shipped
-===================================================================
---- linux-2.6.25.1.orig/scripts/genksyms/parse.c_shipped
-+++ linux-2.6.25.1/scripts/genksyms/parse.c_shipped
+--- a/scripts/genksyms/parse.c_shipped
++++ b/scripts/genksyms/parse.c_shipped
 @@ -160,7 +160,9 @@
  
  
@@ -12,10 +10,8 @@ Index: linux-2.6.25.1/scripts/genksyms/parse.c_shipped
  #include "genksyms.h"
  
  static int is_typedef;
-Index: linux-2.6.25.1/scripts/genksyms/parse.y
-===================================================================
---- linux-2.6.25.1.orig/scripts/genksyms/parse.y
-+++ linux-2.6.25.1/scripts/genksyms/parse.y
+--- a/scripts/genksyms/parse.y
++++ b/scripts/genksyms/parse.y
 @@ -24,7 +24,9 @@
  %{
  
@@ -26,10 +22,8 @@ Index: linux-2.6.25.1/scripts/genksyms/parse.y
  #include "genksyms.h"
  
  static int is_typedef;
-Index: linux-2.6.25.1/scripts/kallsyms.c
-===================================================================
---- linux-2.6.25.1.orig/scripts/kallsyms.c
-+++ linux-2.6.25.1/scripts/kallsyms.c
+--- a/scripts/kallsyms.c
++++ b/scripts/kallsyms.c
 @@ -28,6 +28,35 @@
  #include <stdlib.h>
  #include <string.h>
@@ -66,10 +60,8 @@ Index: linux-2.6.25.1/scripts/kallsyms.c
  
  #define KSYM_NAME_LEN         128
  
-Index: linux-2.6.25.1/scripts/kconfig/Makefile
-===================================================================
---- linux-2.6.25.1.orig/scripts/kconfig/Makefile
-+++ linux-2.6.25.1/scripts/kconfig/Makefile
+--- a/scripts/kconfig/Makefile
++++ b/scripts/kconfig/Makefile
 @@ -93,6 +93,9 @@ check-lxdialog  := $(srctree)/$(src)/lxd
  # we really need to do so. (Do not call gcc as part of make mrproper)
  HOST_EXTRACFLAGS = $(shell $(CONFIG_SHELL) $(check-lxdialog) -ccflags)
@@ -80,10 +72,8 @@ Index: linux-2.6.25.1/scripts/kconfig/Makefile
  
  HOST_EXTRACFLAGS += -DLOCALE
  
-Index: linux-2.6.25.1/scripts/mod/mk_elfconfig.c
-===================================================================
---- linux-2.6.25.1.orig/scripts/mod/mk_elfconfig.c
-+++ linux-2.6.25.1/scripts/mod/mk_elfconfig.c
+--- a/scripts/mod/mk_elfconfig.c
++++ b/scripts/mod/mk_elfconfig.c
 @@ -1,7 +1,11 @@
  #include <stdio.h>
  #include <stdlib.h>
@@ -96,15 +86,13 @@ Index: linux-2.6.25.1/scripts/mod/mk_elfconfig.c
  
  int
  main(int argc, char **argv)
-Index: linux-2.6.25.1/scripts/mod/modpost.h
-===================================================================
---- linux-2.6.25.1.orig/scripts/mod/modpost.h
-+++ linux-2.6.25.1/scripts/mod/modpost.h
+--- a/scripts/mod/modpost.h
++++ b/scripts/mod/modpost.h
 @@ -7,7 +7,11 @@
  #include <sys/mman.h>
  #include <fcntl.h>
  #include <unistd.h>
-+#ifndef __APPLE__
++#if !(defined(__APPLE__) || defined(__CYGWIN__))
  #include <elf.h>
 +#else
 +#include "../../../../../tools/sstrip/include/elf.h"