Update gpiommc to use configfs
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.25 / 921-gpio_spi_driver.patch
index 264386f330d8ae0505104e348632c9233228345d..1249a63188f45f0cbc88540871a0ba4a81df7df0 100644 (file)
@@ -1,8 +1,8 @@
 Index: linux-2.6.25.10/include/linux/spi/spi_gpio.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.25.10/include/linux/spi/spi_gpio.h       2008-07-18 18:19:56.000000000 +0200
-@@ -0,0 +1,67 @@
++++ linux-2.6.25.10/include/linux/spi/spi_gpio.h       2008-07-20 20:10:21.000000000 +0200
+@@ -0,0 +1,73 @@
 +/*
 + * spi_gpio interface to platform code
 + *
@@ -20,7 +20,9 @@ Index: linux-2.6.25.10/include/linux/spi/spi_gpio.h
 +#include <linux/spi/spi.h>
 +
 +
-+/** struct spi_gpio_platform_data - Data definitions for a SPI-GPIO device.
++/**
++ * struct spi_gpio_platform_data - Data definitions for a SPI-GPIO device.
++ *
 + * This structure holds information about a GPIO-based SPI device.
 + *
 + * @pin_clk: The GPIO pin number of the CLOCK pin.
@@ -56,13 +58,17 @@ Index: linux-2.6.25.10/include/linux/spi/spi_gpio.h
 +      void *boardinfo_setup_data;
 +};
 +
-+/** SPI_GPIO_PLATDEV_NAME - The platform device name string.
++/**
++ * SPI_GPIO_PLATDEV_NAME - The platform device name string.
++ *
 + * The name string that has to be used for platform_device_alloc
 + * when allocating a spi-gpio device.
 + */
 +#define SPI_GPIO_PLATDEV_NAME "spi-gpio"
 +
-+/** spi_gpio_next_id - Get another platform device ID number.
++/**
++ * spi_gpio_next_id - Get another platform device ID number.
++ *
 + * This returns the next platform device ID number that has to be used
 + * for platform_device_alloc. The ID is opaque and should not be used for
 + * anything else.
@@ -73,7 +79,7 @@ Index: linux-2.6.25.10/include/linux/spi/spi_gpio.h
 Index: linux-2.6.25.10/drivers/spi/spi_gpio.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.25.10/drivers/spi/spi_gpio.c     2008-07-18 18:19:56.000000000 +0200
++++ linux-2.6.25.10/drivers/spi/spi_gpio.c     2008-07-20 20:10:21.000000000 +0200
 @@ -0,0 +1,251 @@
 +/*
 + * Bitbanging SPI bus driver using GPIO API
@@ -328,8 +334,8 @@ Index: linux-2.6.25.10/drivers/spi/spi_gpio.c
 +MODULE_LICENSE("GPL v2");
 Index: linux-2.6.25.10/drivers/spi/Kconfig
 ===================================================================
---- linux-2.6.25.10.orig/drivers/spi/Kconfig   2008-07-18 18:19:43.000000000 +0200
-+++ linux-2.6.25.10/drivers/spi/Kconfig        2008-07-18 18:19:56.000000000 +0200
+--- linux-2.6.25.10.orig/drivers/spi/Kconfig   2008-07-20 20:09:48.000000000 +0200
++++ linux-2.6.25.10/drivers/spi/Kconfig        2008-07-20 20:11:48.000000000 +0200
 @@ -100,6 +100,19 @@ config SPI_BUTTERFLY
          inexpensive battery powered microcontroller evaluation board.
          This same cable can be used to flash new firmware.
@@ -341,7 +347,7 @@ Index: linux-2.6.25.10/drivers/spi/Kconfig
 +      help
 +        This is a platform driver that can be used for bitbanging
 +        an SPI bus over GPIO pins.
-+        Select this, if you have any SPI device that is connected via
++        Select this if you have any SPI device that is connected via
 +        GPIO pins.
 +        The module will be called spi_gpio.
 +
@@ -352,8 +358,8 @@ Index: linux-2.6.25.10/drivers/spi/Kconfig
        depends on SPI_MASTER && ARCH_IMX && EXPERIMENTAL
 Index: linux-2.6.25.10/drivers/spi/Makefile
 ===================================================================
---- linux-2.6.25.10.orig/drivers/spi/Makefile  2008-07-18 18:19:43.000000000 +0200
-+++ linux-2.6.25.10/drivers/spi/Makefile       2008-07-18 18:19:56.000000000 +0200
+--- linux-2.6.25.10.orig/drivers/spi/Makefile  2008-07-20 20:09:48.000000000 +0200
++++ linux-2.6.25.10/drivers/spi/Makefile       2008-07-20 20:10:21.000000000 +0200
 @@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN)                       += spi_bfin5xx.
  obj-$(CONFIG_SPI_BITBANG)             += spi_bitbang.o
  obj-$(CONFIG_SPI_AU1550)              += au1550_spi.o
@@ -364,8 +370,8 @@ Index: linux-2.6.25.10/drivers/spi/Makefile
  obj-$(CONFIG_SPI_PXA2XX)              += pxa2xx_spi.o
 Index: linux-2.6.25.10/MAINTAINERS
 ===================================================================
---- linux-2.6.25.10.orig/MAINTAINERS   2008-07-03 05:46:47.000000000 +0200
-+++ linux-2.6.25.10/MAINTAINERS        2008-07-18 18:20:28.000000000 +0200
+--- linux-2.6.25.10.orig/MAINTAINERS   2008-07-20 20:09:48.000000000 +0200
++++ linux-2.6.25.10/MAINTAINERS        2008-07-20 20:10:59.000000000 +0200
 @@ -3685,6 +3685,11 @@ M:      dbrownell@users.sourceforge.net
  L:    spi-devel-general@lists.sourceforge.net
  S:    Maintained