[8.09] kernel: refresh patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.25 / 922-gpiommc.patch
index 8bb4c99bcd0073caa27d86f8c11378e1aca740a2..f261af85582c5d9ee9784b6d2ecbabdb66bbbbcd 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.25.10/drivers/mmc/host/gpiommc.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.25.10/drivers/mmc/host/gpiommc.c 2008-07-20 20:49:16.000000000 +0200
+--- /dev/null
++++ b/drivers/mmc/host/gpiommc.c
 @@ -0,0 +1,608 @@
 +/*
 + * Driver an MMC/SD card on a bitbanging GPIO SPI bus.
@@ -611,10 +609,8 @@ Index: linux-2.6.25.10/drivers/mmc/host/gpiommc.c
 +      platform_driver_unregister(&gpiommc_plat_driver);
 +}
 +module_exit(gpiommc_modexit);
-Index: linux-2.6.25.10/drivers/mmc/host/Kconfig
-===================================================================
---- linux-2.6.25.10.orig/drivers/mmc/host/Kconfig      2008-07-20 20:32:22.000000000 +0200
-+++ linux-2.6.25.10/drivers/mmc/host/Kconfig   2008-07-20 20:33:20.000000000 +0200
+--- a/drivers/mmc/host/Kconfig
++++ b/drivers/mmc/host/Kconfig
 @@ -130,3 +130,27 @@ config MMC_SPI
  
          If unsure, or if your system has no SPI master driver, say N.
@@ -643,20 +639,16 @@ Index: linux-2.6.25.10/drivers/mmc/host/Kconfig
 +      help
 +        This option automatically enables configfs support for gpiommc
 +        if configfs is available.
-Index: linux-2.6.25.10/drivers/mmc/host/Makefile
-===================================================================
---- linux-2.6.25.10.orig/drivers/mmc/host/Makefile     2008-07-20 20:32:22.000000000 +0200
-+++ linux-2.6.25.10/drivers/mmc/host/Makefile  2008-07-20 20:33:20.000000000 +0200
+--- a/drivers/mmc/host/Makefile
++++ b/drivers/mmc/host/Makefile
 @@ -17,4 +17,4 @@ obj-$(CONFIG_MMC_OMAP)               += omap.o
  obj-$(CONFIG_MMC_AT91)                += at91_mci.o
  obj-$(CONFIG_MMC_TIFM_SD)     += tifm_sd.o
  obj-$(CONFIG_MMC_SPI)         += mmc_spi.o
 -
 +obj-$(CONFIG_GPIOMMC)         += gpiommc.o
-Index: linux-2.6.25.10/include/linux/mmc/gpiommc.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.25.10/include/linux/mmc/gpiommc.h        2008-07-20 20:33:20.000000000 +0200
+--- /dev/null
++++ b/include/linux/mmc/gpiommc.h
 @@ -0,0 +1,71 @@
 +/*
 + * Device driver for MMC/SD cards driven over a GPIO bus.
@@ -729,10 +721,8 @@ Index: linux-2.6.25.10/include/linux/mmc/gpiommc.h
 +int gpiommc_next_id(void);
 +
 +#endif /* LINUX_GPIOMMC_H_ */
-Index: linux-2.6.25.10/Documentation/gpiommc.txt
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.25.10/Documentation/gpiommc.txt  2008-07-20 20:33:20.000000000 +0200
+--- /dev/null
++++ b/Documentation/gpiommc.txt
 @@ -0,0 +1,97 @@
 +GPIOMMC - Driver for an MMC/SD card on a bitbanging GPIO SPI bus
 +================================================================
@@ -831,10 +821,8 @@ Index: linux-2.6.25.10/Documentation/gpiommc.txt
 +(/config/gpiommc/my_mmc in this example).
 +There's no need to first unregister the device before removing it. That will
 +be done automatically.
-Index: linux-2.6.25.10/MAINTAINERS
-===================================================================
---- linux-2.6.25.10.orig/MAINTAINERS   2008-07-20 20:33:20.000000000 +0200
-+++ linux-2.6.25.10/MAINTAINERS        2008-07-20 20:33:20.000000000 +0200
+--- a/MAINTAINERS
++++ b/MAINTAINERS
 @@ -1736,6 +1736,11 @@ L:      gigaset307x-common@lists.sourceforge.
  W:    http://gigaset307x.sourceforge.net/
  S:    Maintained