merge netfilter kernel changes to 2.6.26 as well
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.26 / 150-netfilter_imq.patch
index 542c54ebbfce00b849a09e25b478091393955f2d..d18e0cb5d6601cb3957d339a5bf5508e459faa94 100644 (file)
@@ -1,6 +1,6 @@
 --- /dev/null
 +++ b/drivers/net/imq.c
-@@ -0,0 +1,464 @@
+@@ -0,0 +1,474 @@
 +/*
 + *             Pseudo-driver for the intermediate queue device.
 + *
 + *             I didn't forget anybody). I apologize again for my lack of time.
 + *
 + *
-+ *             2008/06/07 - Changed imq.c to use qdisc_run() instead of
-+ *             qdisc_restart() and moved qdisc_run() to tasklet to avoid
-+ *             recursive locking. (Jussi Kivilinna)
++ *             2008/06/17 - 2.6.25 - Changed imq.c to use qdisc_run() instead
++ *           of qdisc_restart() and moved qdisc_run() to tasklet to avoid
++ *             recursive locking. New initialization routines to fix 'rmmod' not
++ *             working anymore. Used code from ifb.c. (Jussi Kivilinna)
 + *
++ *           Also, many thanks to pablo Sebastian Greco for making the initial
++ *           patch and to those who helped the testing.
 + *
 + *             More info at: http://www.linuximq.net/ (Andre Correa)
 + */
@@ -76,7 +79,7 @@
 +
 +struct imq_private {
 +      struct tasklet_struct tasklet;
-+      int tasklet_pending;
++      unsigned long tasklet_pending;
 +};
 +
 +static nf_hookfn imq_nf_hook;
 +#if defined(CONFIG_IMQ_NUM_DEVS)
 +static unsigned int numdevs = CONFIG_IMQ_NUM_DEVS;
 +#else
-+static unsigned int numdevs = 16;
++static unsigned int numdevs = IMQ_MAX_DEVS;
 +#endif
 +
-+static struct net_device *imq_devs;
++static struct net_device *imq_devs_cache[IMQ_MAX_DEVS];
 +
 +static struct net_device_stats *imq_get_stats(struct net_device *dev)
 +{
 +      if (index > numdevs)
 +              return -1;
 +
-+      dev = imq_devs + index;
++      /* check for imq device by index from cache */
++      dev = imq_devs_cache[index];
++      if (!dev) {
++              char buf[8];
++
++              /* get device by name and cache result */
++              snprintf(buf, sizeof(buf), "imq%d", index);
++              dev = dev_get_by_name(&init_net, buf);
++              if (!dev) {
++                      /* not found ?!*/
++                      BUG();
++                      return -1;
++              }
++
++              imq_devs_cache[index] = dev;
++      }
++
 +      priv = netdev_priv(dev);
 +      if (!(dev->flags & IFF_UP)) {
 +              entry->skb->imq_flags = 0;
 +                      ret = 0;
 +              }
 +      }
-+
-+      spin_unlock_bh(&dev->queue_lock);
-+
 +      if (!test_and_set_bit(1, &priv->tasklet_pending))
 +              tasklet_schedule(&priv->tasklet);
++      spin_unlock_bh(&dev->queue_lock);
 +
 +      if (skb2)
 +              kfree_skb(ret ? entry->skb : skb2);
 +
 +      spin_lock(&dev->queue_lock);
 +      qdisc_run(dev);
-+      spin_unlock(&dev->queue_lock);
-+
 +      clear_bit(1, &priv->tasklet_pending);
++      spin_unlock(&dev->queue_lock);
 +}
 +
 +static unsigned int imq_nf_hook(unsigned int hook, struct sk_buff *pskb,
 +      return 0;
 +}
 +
++static void imq_setup(struct net_device *dev)
++{
++      dev->hard_start_xmit    = imq_dev_xmit;
++      dev->open               = imq_open;
++      dev->get_stats          = imq_get_stats;
++      dev->stop               = imq_close;
++      dev->type               = ARPHRD_VOID;
++      dev->mtu                = 16000;
++      dev->tx_queue_len       = 11000;
++      dev->flags              = IFF_NOARP;
++}
++
++static struct rtnl_link_ops imq_link_ops __read_mostly = {
++      .kind           = "imq",
++      .priv_size      = sizeof(struct imq_private),
++      .setup          = imq_setup,
++};
++
 +static int __init imq_init_hooks(void)
 +{
 +      int err;
 +      return err;
 +}
 +
-+static void __exit imq_unhook(void)
-+{
-+#if defined(CONFIG_IPV6) || defined(CONFIG_IPV6_MODULE)
-+      nf_unregister_hook(&imq_ingress_ipv6);
-+      nf_unregister_hook(&imq_egress_ipv6);
-+      nf_unregister_queue_handler(PF_INET6, &nfqh);
-+#endif
-+      nf_unregister_hook(&imq_ingress_ipv4);
-+      nf_unregister_hook(&imq_egress_ipv4);
-+      nf_unregister_queue_handler(PF_INET, &nfqh);
-+}
-+
-+static int __init imq_dev_init(struct net_device *dev)
++static int __init imq_init_one(int index)
 +{
-+      dev->hard_start_xmit    = imq_dev_xmit;
-+      dev->open               = imq_open;
-+      dev->get_stats          = imq_get_stats;
-+      dev->stop               = imq_close;
-+      dev->type               = ARPHRD_VOID;
-+      dev->mtu                = 16000;
-+      dev->tx_queue_len       = 11000;
-+      dev->flags              = IFF_NOARP;
++      struct net_device *dev;
++      int ret;
 +
-+      dev->priv = kzalloc(sizeof(struct imq_private), GFP_KERNEL);
-+      if (dev->priv == NULL)
++      dev = alloc_netdev(sizeof(struct imq_private), "imq%d", imq_setup);
++      if (!dev)
 +              return -ENOMEM;
 +
-+      return 0;
-+}
++      ret = dev_alloc_name(dev, dev->name);
++      if (ret < 0)
++              goto fail;
 +
-+static void imq_dev_uninit(struct net_device *dev)
-+{
-+      kfree(dev->priv);
++      dev->rtnl_link_ops = &imq_link_ops;
++      ret = register_netdevice(dev);
++      if (ret < 0)
++              goto fail;
++
++      return 0;
++fail:
++      free_netdev(dev);
++      return ret;
 +}
 +
-+static int __init imq_init_devs(struct net *net)
++static int __init imq_init_devs(void)
 +{
-+      struct net_device *dev;
-+      int i, j;
++      int err, i;
 +
 +      if (!numdevs || numdevs > IMQ_MAX_DEVS) {
 +              printk(KERN_ERR "IMQ: numdevs has to be betweed 1 and %u\n",
 +              return -EINVAL;
 +      }
 +
-+      imq_devs = kzalloc(sizeof(struct net_device) * numdevs, GFP_KERNEL);
-+      if (!imq_devs)
-+              return -ENOMEM;
++      rtnl_lock();
++      err = __rtnl_link_register(&imq_link_ops);
 +
-+      /* we start counting at zero */
-+      j = numdevs - 1;
++      for (i = 0; i < numdevs && !err; i++)
++              err = imq_init_one(i);
 +
-+      for (i = 0, dev = imq_devs; i <= j; i++, dev++) {
-+              strcpy(dev->name, "imq%d");
-+              dev->init   = imq_dev_init;
-+              dev->uninit = imq_dev_uninit;
-+              dev->nd_net = net;
-+
-+              if (register_netdev(dev) < 0)
-+                      goto err_register;
++      if (err) {
++              __rtnl_link_unregister(&imq_link_ops);
++              memset(imq_devs_cache, 0, sizeof(imq_devs_cache));
 +      }
-+      printk(KERN_INFO "IMQ starting with %u devices...\n", numdevs);
-+      return 0;
-+
-+err_register:
-+      for (; i; i--)
-+              unregister_netdev(--dev);
-+      kfree(imq_devs);
-+      return -EIO;
-+}
-+
-+static void imq_cleanup_devs(void)
-+{
-+      int i;
-+      struct net_device *dev = imq_devs;
++      rtnl_unlock();
 +
-+      for (i = 0; i <= numdevs; i++)
-+              unregister_netdev(dev++);
-+
-+      kfree(imq_devs);
++      return err;
 +}
 +
-+static __net_init int imq_init_module(struct net *net)
++static int __init imq_init_module(void)
 +{
 +      int err;
 +
-+      err = imq_init_devs(net);
++      err = imq_init_devs();
 +      if (err) {
 +              printk(KERN_ERR "IMQ: Error trying imq_init_devs(net)\n");
 +              return err;
 +      err = imq_init_hooks();
 +      if (err) {
 +              printk(KERN_ERR "IMQ: Error trying imq_init_hooks()\n");
-+              imq_cleanup_devs();
++              rtnl_link_unregister(&imq_link_ops);
++              memset(imq_devs_cache, 0, sizeof(imq_devs_cache));
 +              return err;
 +      }
 +
 +      return 0;
 +}
 +
-+static __net_exit void imq_exit_module(struct net *net)
++static void __exit imq_unhook(void)
 +{
-+      imq_unhook();
-+      imq_cleanup_devs();
-+      printk(KERN_INFO "IMQ driver unloaded successfully.\n");
++#if defined(CONFIG_IPV6) || defined(CONFIG_IPV6_MODULE)
++      nf_unregister_hook(&imq_ingress_ipv6);
++      nf_unregister_hook(&imq_egress_ipv6);
++      nf_unregister_queue_handler(PF_INET6, &nfqh);
++#endif
++      nf_unregister_hook(&imq_ingress_ipv4);
++      nf_unregister_hook(&imq_egress_ipv4);
++      nf_unregister_queue_handler(PF_INET, &nfqh);
 +}
 +
-+static struct pernet_operations __net_initdata imq_net_ops = {
-+      .init = imq_init_module,
-+      .exit = imq_exit_module,
-+};
++static void __exit imq_cleanup_devs(void)
++{
++      rtnl_link_unregister(&imq_link_ops);
++      memset(imq_devs_cache, 0, sizeof(imq_devs_cache));
++}
 +
-+static int __init imq_init(void)
++static void __exit imq_exit_module(void)
 +{
-+      return register_pernet_device(&imq_net_ops);
++      imq_unhook();
++      imq_cleanup_devs();
++      printk(KERN_INFO "IMQ driver unloaded successfully.\n");
 +}
 +
-+module_init(imq_init);
-+/*module_exit(imq_cleanup_module);*/
++module_init(imq_init_module);
++module_exit(imq_exit_module);
 +
 +module_param(numdevs, int, 0);
 +MODULE_PARM_DESC(numdevs, "number of IMQ devices (how many imq* devices will "
 +MODULE_DESCRIPTION("Pseudo-driver for the intermediate queue device. See "
 +                      "http://www.linuximq.net/ for more information.");
 +MODULE_LICENSE("GPL");
++MODULE_ALIAS_RTNL_LINK("imq");
 +
 --- a/drivers/net/Kconfig
 +++ b/drivers/net/Kconfig
-@@ -117,6 +117,129 @@
+@@ -117,6 +117,129 @@ config EQUALIZER
          To compile this driver as a module, choose M here: the module
          will be called eql.  If unsure, say N.
  
 +choice
 +      prompt "IMQ behavior (PRE/POSTROUTING)"
 +      depends on IMQ
-+      default IMQ_BEHAVIOR_BB
++      default IMQ_BEHAVIOR_AB
 +      help
 +
 +              This settings defines how IMQ behaves in respect to its
        select CRC32
 --- a/drivers/net/Makefile
 +++ b/drivers/net/Makefile
-@@ -142,6 +142,7 @@
+@@ -142,6 +142,7 @@ obj-$(CONFIG_SLHC) += slhc.o
  obj-$(CONFIG_XEN_NETDEV_FRONTEND) += xen-netfront.o
  
  obj-$(CONFIG_DUMMY) += dummy.o
 +#endif /* _IP6T_IMQ_H */
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -300,6 +300,10 @@
+@@ -300,6 +300,10 @@ struct sk_buff {
        struct nf_conntrack     *nfct;
        struct sk_buff          *nfct_reasm;
  #endif
  #ifdef CONFIG_BRIDGE_NETFILTER
        struct nf_bridge_info   *nf_bridge;
  #endif
-@@ -1633,6 +1637,10 @@
+@@ -1633,6 +1637,10 @@ static inline void __nf_copy(struct sk_b
        dst->nfct_reasm = src->nfct_reasm;
        nf_conntrack_get_reasm(src->nfct_reasm);
  #endif
  #include <linux/proc_fs.h>
  #include <linux/seq_file.h>
  #include <linux/stat.h>
-@@ -1545,7 +1548,11 @@
+@@ -1569,7 +1572,11 @@ static int dev_gso_segment(struct sk_buf
  int dev_hard_start_xmit(struct sk_buff *skb, struct net_device *dev)
  {
        if (likely(!skb->next)) {
 +                             const struct xt_target *target,
 +                             const void *targinfo)
 +{
-+      struct ipt_imq_info *mr = (struct ipt_imq_info*)targinfo;
++      struct ipt_imq_info *mr = (struct ipt_imq_info *)targinfo;
 +
 +      pskb->imq_flags = mr->todev | IMQ_F_ENQUEUE;
 +
 +{
 +      struct ipt_imq_info *mr;
 +
-+      mr = (struct ipt_imq_info*)targinfo;
++      mr = (struct ipt_imq_info *)targinfo;
 +
 +      if (mr->todev > IMQ_MAX_DEVS) {
 +              printk(KERN_WARNING
 +MODULE_LICENSE("GPL");
 --- a/net/ipv4/netfilter/Kconfig
 +++ b/net/ipv4/netfilter/Kconfig
-@@ -145,6 +145,17 @@
+@@ -123,6 +123,17 @@ config IP_NF_FILTER
  
          To compile it as a module, choose M here.  If unsure, say N.
  
 +config IP_NF_TARGET_IMQ
 +       tristate "IMQ target support"
-+       depends on IP_NF_MANGLE
++       depends on IP_NF_MANGLE && IMQ
 +       help
 +         This option adds a `IMQ' target which is used to specify if and
 +         to which IMQ device packets should get enqueued/dequeued.
        depends on IP_NF_FILTER
 --- a/net/ipv4/netfilter/Makefile
 +++ b/net/ipv4/netfilter/Makefile
-@@ -58,6 +58,7 @@
+@@ -55,6 +55,7 @@ obj-$(CONFIG_IP_NF_MATCH_SET) += ipt_set
  obj-$(CONFIG_IP_NF_TARGET_CLUSTERIP) += ipt_CLUSTERIP.o
  obj-$(CONFIG_IP_NF_TARGET_ECN) += ipt_ECN.o
  obj-$(CONFIG_IP_NF_TARGET_LOG) += ipt_LOG.o
 +                             const struct xt_target *target,
 +                             const void *targinfo)
 +{
-+      struct ip6t_imq_info *mr = (struct ip6t_imq_info*)targinfo;
++      struct ip6t_imq_info *mr = (struct ip6t_imq_info *)targinfo;
 +
 +      pskb->imq_flags = mr->todev | IMQ_F_ENQUEUE;
 +
 +{
 +      struct ip6t_imq_info *mr;
 +
-+      mr = (struct ip6t_imq_info*)targinfo;
++      mr = (struct ip6t_imq_info *)targinfo;
 +
 +      if (mr->todev > IMQ_MAX_DEVS) {
 +              printk(KERN_WARNING
 +MODULE_LICENSE("GPL");
 --- a/net/ipv6/netfilter/Kconfig
 +++ b/net/ipv6/netfilter/Kconfig
-@@ -179,6 +179,15 @@
+@@ -179,6 +179,15 @@ config IP6_NF_MANGLE
  
          To compile it as a module, choose M here.  If unsure, say N.
  
 +config IP6_NF_TARGET_IMQ
 +      tristate "IMQ target support"
-+      depends on IP6_NF_MANGLE
++      depends on IP6_NF_MANGLE && IMQ
 +      help
 +          This option adds a `IMQ' target which is used to specify if and
 +          to which imq device packets should get enqueued/dequeued.
  
 --- a/net/sched/sch_generic.c
 +++ b/net/sched/sch_generic.c
-@@ -203,6 +203,7 @@
+@@ -203,6 +203,7 @@ void __qdisc_run(struct net_device *dev)
  
        clear_bit(__LINK_STATE_QDISC_RUNNING, &dev->state);
  }