[kernel] refresh patches against 2.6.27 final
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.27 / 001-squashfs.patch
index 97ba7635caba32a96119d9220f93a3f670bb86fe..b8176914c1ba6ce9e053bcf5656f3a92266ffcbf 100644 (file)
@@ -1,6 +1,6 @@
 --- a/fs/Kconfig
 +++ b/fs/Kconfig
-@@ -1348,6 +1348,71 @@
+@@ -1348,6 +1348,71 @@ config CRAMFS
  
          If unsure, say N.
  
@@ -74,7 +74,7 @@
        depends on BLOCK
 --- a/fs/Makefile
 +++ b/fs/Makefile
-@@ -74,6 +74,7 @@
+@@ -74,6 +74,7 @@ obj-$(CONFIG_JBD)            += jbd/
  obj-$(CONFIG_JBD2)            += jbd2/
  obj-$(CONFIG_EXT2_FS)         += ext2/
  obj-$(CONFIG_CRAMFS)          += cramfs/
  #include <linux/initrd.h>
  #include <linux/string.h>
  
-@@ -37,6 +38,7 @@
+@@ -37,6 +38,7 @@ static int __init crd_load(int in_fd, in
   * numbers could not be found.
   *
   * We currently check for the following magic numbers:
   *    minix
   *    ext2
   *    romfs
-@@ -51,6 +53,7 @@
+@@ -51,6 +53,7 @@ identify_ramdisk_image(int fd, int start
        struct ext2_super_block *ext2sb;
        struct romfs_super_block *romfsb;
        struct cramfs_super *cramfsb;
        int nblocks = -1;
        unsigned char *buf;
  
-@@ -62,6 +65,7 @@
+@@ -62,6 +65,7 @@ identify_ramdisk_image(int fd, int start
        ext2sb = (struct ext2_super_block *) buf;
        romfsb = (struct romfs_super_block *) buf;
        cramfsb = (struct cramfs_super *) buf;
        memset(buf, 0xe5, size);
  
        /*
-@@ -99,6 +103,15 @@
+@@ -99,6 +103,15 @@ identify_ramdisk_image(int fd, int start
                goto done;
        }