[kernel] update to latest 2.6.27.26 stable kernel
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.27 / 024-mips_disable_fpu.patch
index e71bf48f2103b03b11699765caa8d34948aa7248..60e844b279e104aecee12a19df84b9d9c17a5676 100644 (file)
@@ -6,11 +6,9 @@ precious blocks on an embedded system.
 
 Signed-off-by: Florian Fainelli <florian@openwrt.org>
 --
 
 Signed-off-by: Florian Fainelli <florian@openwrt.org>
 --
-diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
-index 65d3b19..a467ee5 100644
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -811,6 +811,17 @@ config I8259
+@@ -756,6 +756,17 @@ config I8259
  config MIPS_BONITO64
        bool
  
  config MIPS_BONITO64
        bool
  
@@ -28,8 +26,6 @@ index 65d3b19..a467ee5 100644
  config MIPS_MSC
        bool
  
  config MIPS_MSC
        bool
  
-diff --git a/arch/mips/math-emu/Makefile b/arch/mips/math-emu/Makefile
-index d547efd..7fdef24 100644
 --- a/arch/mips/math-emu/Makefile
 +++ b/arch/mips/math-emu/Makefile
 @@ -2,12 +2,14 @@
 --- a/arch/mips/math-emu/Makefile
 +++ b/arch/mips/math-emu/Makefile
 @@ -2,12 +2,14 @@
@@ -49,11 +45,9 @@ index d547efd..7fdef24 100644
 +         dp_sqrt.o sp_sqrt.o
  
  EXTRA_CFLAGS += -Werror
 +         dp_sqrt.o sp_sqrt.o
  
  EXTRA_CFLAGS += -Werror
-diff --git a/arch/mips/math-emu/cp1emu.c b/arch/mips/math-emu/cp1emu.c
-index 890f779..9f4c767 100644
 --- a/arch/mips/math-emu/cp1emu.c
 +++ b/arch/mips/math-emu/cp1emu.c
 --- a/arch/mips/math-emu/cp1emu.c
 +++ b/arch/mips/math-emu/cp1emu.c
-@@ -56,6 +56,12 @@
+@@ -57,6 +57,12 @@
  #endif
  #define __mips 4
  
  #endif
  #define __mips 4
  
@@ -66,7 +60,7 @@ index 890f779..9f4c767 100644
  /* Function which emulates a floating point instruction. */
  
  static int fpu_emu(struct pt_regs *, struct mips_fpu_struct *,
  /* Function which emulates a floating point instruction. */
  
  static int fpu_emu(struct pt_regs *, struct mips_fpu_struct *,
-@@ -66,10 +72,6 @@ static int fpux_emu(struct pt_regs *,
+@@ -67,10 +73,6 @@ static int fpux_emu(struct pt_regs *,
        struct mips_fpu_struct *, mips_instruction);
  #endif
  
        struct mips_fpu_struct *, mips_instruction);
  #endif
  
@@ -77,7 +71,7 @@ index 890f779..9f4c767 100644
  /* Control registers */
  
  #define FPCREG_RID    0       /* $0  = revision id */
  /* Control registers */
  
  #define FPCREG_RID    0       /* $0  = revision id */
-@@ -1273,6 +1275,13 @@ int fpu_emulator_cop1Handler(struct pt_regs *xcp, struct mips_fpu_struct *ctx,
+@@ -1277,6 +1279,13 @@ int fpu_emulator_cop1Handler(struct pt_r
  
        return sig;
  }
  
        return sig;
  }
@@ -91,11 +85,9 @@ index 890f779..9f4c767 100644
  
  #ifdef CONFIG_DEBUG_FS
  extern struct dentry *mips_debugfs_dir;
  
  #ifdef CONFIG_DEBUG_FS
  extern struct dentry *mips_debugfs_dir;
-diff --git a/arch/mips/math-emu/dsemul.c b/arch/mips/math-emu/dsemul.c
-index df7b9d9..9b42bfd 100644
 --- a/arch/mips/math-emu/dsemul.c
 +++ b/arch/mips/math-emu/dsemul.c
 --- a/arch/mips/math-emu/dsemul.c
 +++ b/arch/mips/math-emu/dsemul.c
-@@ -109,6 +109,7 @@ int mips_dsemul(struct pt_regs *regs, mips_instruction ir, unsigned long cpc)
+@@ -110,6 +110,7 @@ int mips_dsemul(struct pt_regs *regs, mi
        return SIGILL;          /* force out of emulation loop */
  }
  
        return SIGILL;          /* force out of emulation loop */
  }
  
@@ -103,7 +95,7 @@ index df7b9d9..9b42bfd 100644
  int do_dsemulret(struct pt_regs *xcp)
  {
        struct emuframe __user *fr;
  int do_dsemulret(struct pt_regs *xcp)
  {
        struct emuframe __user *fr;
-@@ -165,3 +166,9 @@ int do_dsemulret(struct pt_regs *xcp)
+@@ -166,3 +167,9 @@ int do_dsemulret(struct pt_regs *xcp)
  
        return 1;
  }
  
        return 1;
  }
@@ -113,8 +105,6 @@ index df7b9d9..9b42bfd 100644
 +      return 0;
 +}
 +#endif /* CONFIG_MIPS_FPU_EMU */
 +      return 0;
 +}
 +#endif /* CONFIG_MIPS_FPU_EMU */
-diff --git a/arch/mips/math-emu/kernel_linkage.c b/arch/mips/math-emu/kernel_linkage.c
-index 52e6c58..211a399 100644
 --- a/arch/mips/math-emu/kernel_linkage.c
 +++ b/arch/mips/math-emu/kernel_linkage.c
 @@ -29,6 +29,7 @@
 --- a/arch/mips/math-emu/kernel_linkage.c
 +++ b/arch/mips/math-emu/kernel_linkage.c
 @@ -29,6 +29,7 @@
@@ -125,7 +115,7 @@ index 52e6c58..211a399 100644
  void fpu_emulator_init_fpu(void)
  {
        static int first = 1;
  void fpu_emulator_init_fpu(void)
  {
        static int first = 1;
-@@ -112,4 +113,34 @@ int fpu_emulator_restore_context32(struct sigcontext32 __user *sc)
+@@ -112,4 +113,34 @@ int fpu_emulator_restore_context32(struc
  
        return err;
  }
  
        return err;
  }