the 'dev' member of the structure was removed in 2.6.27 (see:
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.27 / 200-sched_esfq.patch
index 9402a5794d63d4732a008c0588f4a37c0c321d2c..ef4c21f771444174f01aa08ca9f91065c5166cd5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/pkt_sched.h
 +++ b/include/linux/pkt_sched.h
 --- a/include/linux/pkt_sched.h
 +++ b/include/linux/pkt_sched.h
-@@ -173,8 +173,37 @@
+@@ -173,8 +173,37 @@ struct tc_sfq_xstats
   *
   *    The only reason for this is efficiency, it is possible
   *    to change these parameters in compile time.
   *
   *    The only reason for this is efficiency, it is possible
   *    to change these parameters in compile time.
@@ -40,7 +40,7 @@
  enum
 --- a/net/sched/Kconfig
 +++ b/net/sched/Kconfig
  enum
 --- a/net/sched/Kconfig
 +++ b/net/sched/Kconfig
-@@ -128,6 +128,37 @@
+@@ -128,6 +128,37 @@ config NET_SCH_SFQ
          To compile this code as a module, choose M here: the
          module will be called sch_sfq.
  
          To compile this code as a module, choose M here: the
          module will be called sch_sfq.
  
@@ -80,7 +80,7 @@
        ---help---
 --- a/net/sched/Makefile
 +++ b/net/sched/Makefile
        ---help---
 --- a/net/sched/Makefile
 +++ b/net/sched/Makefile
-@@ -23,6 +23,7 @@
+@@ -23,6 +23,7 @@ obj-$(CONFIG_NET_SCH_GRED)   += sch_gred.o
  obj-$(CONFIG_NET_SCH_INGRESS) += sch_ingress.o 
  obj-$(CONFIG_NET_SCH_DSMARK)  += sch_dsmark.o
  obj-$(CONFIG_NET_SCH_SFQ)     += sch_sfq.o
  obj-$(CONFIG_NET_SCH_INGRESS) += sch_ingress.o 
  obj-$(CONFIG_NET_SCH_DSMARK)  += sch_dsmark.o
  obj-$(CONFIG_NET_SCH_SFQ)     += sch_sfq.o
 +      struct esfq_sched_data *q = qdisc_priv(sch);
 +      int err;
 +
 +      struct esfq_sched_data *q = qdisc_priv(sch);
 +      int err;
 +
-+      q->quantum = psched_mtu(sch->dev); /* default */
++      q->quantum = psched_mtu(qdisc_dev(sch)); /* default */
 +      if ((err = esfq_q_init(q, opt)))
 +              return err;
 +
 +      if ((err = esfq_q_init(q, opt)))
 +              return err;
 +
 +
 +      /* set up new queue */
 +      memset(&new, 0, sizeof(struct esfq_sched_data));
 +
 +      /* set up new queue */
 +      memset(&new, 0, sizeof(struct esfq_sched_data));
-+      new.quantum = psched_mtu(sch->dev); /* default */
++      new.quantum = psched_mtu(qdisc_dev(sch)); /* default */
 +      if ((err = esfq_q_init(&new, opt)))
 +              return err;
 +
 +      if ((err = esfq_q_init(&new, opt)))
 +              return err;
 +