kernel: add driver for the RTL8366RB switch
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.30 / 691-phy_rtl8366.patch
index 6223f00fe7355c3545adacf3488d641058b1323f..4ce0520b11a8f6bfcca9a0c820b7a43b9d8a1e96 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -135,4 +135,25 @@ config MDIO_GPIO
+@@ -135,4 +135,29 @@ config MDIO_GPIO
          To compile this driver as a module, choose M here: the module
          will be called mdio-gpio.
  
 +      tristate "Driver for the Realtek RTL8366S switch"
 +      select SWCONFIG
 +
++config RTL8366RB_PHY
++      tristate "Driver for the Realtek RTL8366RB switch"
++      select SWCONFIG
++
 +config RTL8366S_PHY_DEBUG_FS
-+      bool "RTL8366S switch driver DEBUG_FS support"
-+      depends on RTL8366S_PHY
++      bool "RTL8366 switch driver DEBUG_FS support"
++      depends on RTL8366S_PHY || RTL8366RB_PHY
 +      depends on DEBUG_FS
 +      default n
 +
  endif # PHYLIB
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -19,6 +19,8 @@ obj-$(CONFIG_IP175C_PHY)     += ip175c.o
+@@ -19,6 +19,9 @@ obj-$(CONFIG_IP175C_PHY)     += ip175c.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
  obj-$(CONFIG_AR8216_PHY)      += ar8216.o
  obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o
 +obj-$(CONFIG_RTL8366_SMI)     += rtl8366_smi.o
 +obj-$(CONFIG_RTL8366S_PHY)    += rtl8366s.o
++obj-$(CONFIG_RTL8366RB_PHY)   += rtl8366rb.o
  obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o
  obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o