[kernel] pwm: export the generic pwm api as module
[openwrt/svn-archive/archive.git] / target / linux / generic / files / drivers / pwm / Makefile
index e8cacc5740066273b9ec4fdb5fee39e46f26c1a1..af22041bf2b26ee1f0efeec1a4dec5e302ac7b0f 100644 (file)
@@ -1,6 +1,6 @@
 #
 # Makefile for pwm devices
 #
-obj-y := pwm.o
+obj-$(CONFIG_GENERIC_PWM) := pwm.o
 obj-$(CONFIG_ATMEL_PWM)                += atmel-pwm.o
-obj-$(CONFIG_GPIO_PWM)         += gpio.o
+obj-$(CONFIG_GPIO_PWM)         += gpio-pwm.o