kernel: use -fno-caller-saves
[openwrt/svn-archive/archive.git] / target / linux / generic / patches-2.6.37 / 012-extra_optimization.patch
index d7066486fc565866c97190596ebc6a4cf45318f2..4ffa26e9eba166a5ad3a891bc147ec1154be9ae3 100644 (file)
@@ -1,15 +1,18 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -540,7 +540,7 @@ all: vmlinux
+@@ -538,9 +538,9 @@
+ all: vmlinux
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
- KBUILD_CFLAGS += -Os
+-KBUILD_CFLAGS += -Os
++KBUILD_CFLAGS += -Os -fno-caller-saves
  else
 -KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile
-@@ -595,6 +595,9 @@ endif
+@@ -595,6 +595,9 @@
  NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
  CHECKFLAGS     += $(NOSTDINC_FLAGS)