kernel: use -fno-caller-saves
[openwrt/svn-archive/archive.git] / target / linux / generic / patches-2.6.38 / 012-extra_optimization.patch
index 4984fad29b06743aefcca65415a19b9eeda0a3c8..d173e4c75372689aac09ba1a4792847677082b07 100644 (file)
@@ -1,11 +1,14 @@
 --- a/Makefile
 +++ b/Makefile
 --- a/Makefile
 +++ b/Makefile
-@@ -541,7 +541,7 @@ all: vmlinux
+@@ -539,9 +539,9 @@ endif # $(dot-config)
+ all: vmlinux
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
- KBUILD_CFLAGS += -Os
+-KBUILD_CFLAGS += -Os
++KBUILD_CFLAGS += -Os -fno-caller-saves
  else
 -KBUILD_CFLAGS += -O2
  else
 -KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile