kernel/3.1[02]: move MTD root device setup code to mtdcore
[openwrt/svn-archive/archive.git] / target / linux / generic / patches-3.10 / 643-bridge_remove_ipv6_dependency.patch
index 49986da1b2664337c9530db5e8568ec3bc370334..4e34d51855bda27fb5536506e728a16ad80c99c0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/net/addrconf.h
 +++ b/include/net/addrconf.h
-@@ -99,6 +99,12 @@ extern void                 addrconf_join_solict(struc
+@@ -103,6 +103,12 @@ extern void                       addrconf_join_solict(struc
  extern void                   addrconf_leave_solict(struct inet6_dev *idev,
                                        const struct in6_addr *addr);
  
          Ethernet bridge, which means that the different Ethernet segments it
 --- a/net/ipv6/Makefile
 +++ b/net/ipv6/Makefile
-@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o 
+@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o
  obj-$(CONFIG_INET) += output_core.o protocol.o $(ipv6-offload)
  
  obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_hashtables.o
 +obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_stubs.o
 --- a/net/ipv6/addrconf.c
 +++ b/net/ipv6/addrconf.c
-@@ -1321,7 +1321,7 @@ out:
+@@ -1319,7 +1319,7 @@ out:
        return ret;
  }
  
@@ -41,7 +41,7 @@
                       const struct in6_addr *daddr, unsigned int prefs,
                       struct in6_addr *saddr)
  {
-@@ -1446,7 +1446,6 @@ try_nextdev:
+@@ -1444,7 +1444,6 @@ try_nextdev:
        in6_ifa_put(hiscore->ifa);
        return 0;
  }
@@ -49,7 +49,7 @@
  
  int __ipv6_get_lladdr(struct inet6_dev *idev, struct in6_addr *addr,
                      unsigned char banned_flags)
-@@ -5145,6 +5144,9 @@ int __init addrconf_init(void)
+@@ -5170,6 +5169,9 @@ int __init addrconf_init(void)
  
        ipv6_addr_label_rtnl_register();
  
@@ -59,7 +59,7 @@
        return 0;
  errout:
        rtnl_af_unregister(&inet6_ops);
-@@ -5163,6 +5165,9 @@ void addrconf_cleanup(void)
+@@ -5188,6 +5190,9 @@ void addrconf_cleanup(void)
        struct net_device *dev;
        int i;